Headings twisted when drone takes off

I have three F550 drones.
After completing the QGC setting and completing the indoor flight test
I did an outdoor flight.
The Yaw was twisted on the first take-off, and the flight became fine after returning the Yaw direction.
It took off again after landing, but Yaw turned in the same direction. All three F450 drones I have set up the same thing, and all of them have the same phenomenon.
Please advise if you have experienced the same phenomenon, solved it, or know how to solve it.
I set the PX4 Firmware version to 1.13.3, and I will attach the log record as well.


Are you using an external GPS with included mag and what is the orientation of it?

I’m using an external GPS and I’m looking forward in the same direction as the cuav v5+.
We also finished calibrating compass, gyroscope, accelometer, and level horizon in open areas without electromagnetic fields.
Yaw only turns on the first take-off, and if you turn Yaw back in place, it will no longer turn.
Attach GPS mounting location information as a picture.

The FC I’m currently using is cuav v5+, and the GPS is no V2 gnss.

I recently had a similar problem, where I got a Yaw rotation after takeoff, which always had the same direction. Looking at your log file, I think it might be a similar issue you are dealing with.

The Actuator Controls plot shows a constant offset in yaw, which suggests that the controller might be working against an imbalance. Additionally, the Actuator Outputs plot shows that two of the motors constantly spin faster than the other two. Depending on your configuration regarding the direction of the motors, this could potentially be the root of the issue. Could you give some information on that?
I honestly don’t really know what the problem could be, hardware wise. In my case it was due to the custom frame I use and some of the motors being slightly tilted, which resulted in a yaw rotation due to a minor portion of sidewards thrust some motors produced. But with a frame like you are using, this schouldn’t be a possibility.

I didn’t quite understand what the information was about the actuator outputs plot.

The motor I have is T2212-920KV (two ccws, two cws),
The propella uses 8 inches.

I didn’t quite understand what the information was about the actuator outputs plot.

The Actuator Outputs in your flight log show an offset between two groups of motors. The motors/ESCs connected to output 0 and 1 get a command of around 1650 ms, while the motors/ESCs connected to output 2 and 3 get a command of less than 1500 ms, if I see that correctly. This means that the first group spins faster. This can have various reasons, I imagine.
In my case, the motors with spinning direction CW were spinning faster than the motors with CCW direction. This was caused by a slight misconfiguration, so the controller just counteracted an offset in yaw rotation.

Now in order to determine if this might also be your case, I need to know which motor (number in config) corresponds to which physical motor. If you used the same numbering like it is shown in the documentation (image below), then you might have a similar problem.

Thank you for your answer.
The previously recorded data will be deleted by setting up a new firmware for FC now.

I will try to reset it and let you know in the reply.
At that time, I would appreciate it if you could tell me how to set it up or know-how.

I think your setup isn’t necessarily the issue. I just think that there might be a problem with one of the motors/rotors. It could be a misalignment of the axis, like it was in my case, but it could also be something different.

As a reference, here is a log of a testflight I did with my custom drone some time ago, before I fixed the issue with a slight twist after takeoff: https://review.px4.io/plot_app?log=7aa15cd0-9466-4222-9162-3a54fa2d7680
Take a look at the Actuator Controls plot, there is a constant negative offset in yaw command. With the z-axis pointing downwards, by the right hand rule this means the flight controller commands a rotation in the counterclockwise direction. It does this to keep a stable heading, because misaligned motor axes made it constantly rotate clockwise when motors rotated at equal speeds.
The Motor Outputs plot proves this point. We have two groups of motors. Uneven motors (1,3,5) spin clockwise while even motors (2,4,6) spin counterclockwise. The uneven motors spin faster, to produce a counterclockwise rotation to act against the natural clockwise rotation I mentioned above.

Since your plot looks rather similar to my plots and you also observed a similar behavior, it’s very likely you are dealing with a similar problem. So I would recommend you to do the following: Make another test when you made your firmware changes and get the log to see if the problem is still present. If it is, attach it to a rope, to lift it off the ground while being able to yaw freely. Then just arm in position mode which should make the motors spin at min level. Since the motors spin equally, you can check if you get a constant rotation or not. If you do, then you’d need to check your hardware setup.

First, if the header goes around even in alt-hold or stabilize mode, it’s not a matter of compass or gps.

Second, if the heading is turned in flight mode using a gps or compass sensor, such as Loiter mode, it is recommended to check the parameter that sets the sensor.

So let’s estimate the range of failures.

Thank you for your reply.

If I need to check my hardware settings, what should I check?

Thank you for your reply.
It does not rotate in Alt-Hold or Stabilize Mode.
There is a problem when flying using GPS.

What should I check for the parameters that set the sensor?

For your information, there will only be a head turn when taking off, but this problem will not occur if you turn the head back to the front.
I wonder if this can be seen as a hardware problem.

First, compass calibration
-Inflight calibration is recommended.

Second, check the parameters related to CAL_MAG0_ROT.

Is it possible?

In my case it was a slight misalignment of some of the motor axes, due to my custom frame. But in your case with a commercial frame, I think this is rather unlikely, but you should still check as good as you can. Another thing I suggest is to try and swap the rotors, if you have any spare ones. This might also help narrowing down the origin of the problem.

After completing the compass calibration
CAL_MAG0_ROT parameter check result
It says internal.

Change the Compass setting to external, and change Compass No. 1 to the Compass sensor built into the gps. Is it possible?

I’m sorry, but I’d like you to tell me how to set it up.
Currently I’m using QGC, and I don’t know how to change it.
The parameter GPS_1_GONFIG is currently set to GPS1. But I don’t know if this is right.
Thank you for your help.

I did a flight test after setting the px4 firmware 1.13.0 version in QGC today. The flight test was conducted after flying indoors in stabilized mode.
After replacing with a new propeller, no particular singularities were found when conducting flight tests indoors.
After that, we conducted an outdoor flight test and conducted the flight in position mode.
During the outdoor flight, my F450 drone took off as the yaw turned about 90 degrees to the right as soon as it took off, and when the yaw was returned, the aircraft left.There was a tremor to the right. I kept hovering to watch the tremor, and I made no progress, so I landed. After landing, the compass calibration was carried out again, and when the aircraft was taken off, it continued to flip over.

In my opinion, there may be a hardware problem apart from the GPS problem.If you know the solution to this problem, please reply.
I will attach the log record below and other necessary attachments.

Interior flight log record

  1. https://review.px4.io/plot_app?log=34468592-8eca-4712-aade-621cd0f299d9
  2. https://review.px4.io/plot_app?log=352a0728-2c0b-4556-9183-7024110e4721
  3. https://review.px4.io/plot_app?log=294bad86-81ce-4b0a-9e23-fcb06082518a

Record outdoor flight log

  1. yaw turn

F450 Drone(The motor uses T2212-920KV)

Current QGC actuator status

I also have an additional question.

First, if I watch YouTube when I proceed with the compass calibration after resetting the firmware in QGC, is it correct to proceed indoors and then do it again before the outdoor flight?
If the above method is wrong, please let me know the exact method in detail.

Second, if there is a way to change the compass setting to external in QGC and change the compass number 1 to the compass sensor built into the GPS, please = let me know.

Thank you for reading the long article, and if you have experienced and solved the above phenomenon, please help us.

미션파일을 보아하니 한국사람 같은데 편하게 한국어로 답변 드려도 될까요?

예, 편하게 한국말로 하셔도됩니다
빨리 문제를 해결하고 싶네요ㅠㅠ
카톡 아이디라도 알려드릴까요?ㅠㅠ

i think you drone is yawing to the north pole direction of earth, check in compass the north pole direction , and takeoff your drone by placing the head of the drone in north pole direction,it will not yaw .i have been facing this issue but didnt found a proper solution for that yet.if someone has a solution for this, please let me know.