Fixed wing did not follow a given mission path,and crashed

Hi guys! I have built a fixed wing this week using Pixhawk4 mini ,newest firmware and then choose StandardPlane as airframe. after a serise of pre-work I tried it in mission mode,I gave it some waypoints, and end with landing pattern,but its real flight route is totally different from the path I set,I read the flight log(https://logs.px4.io/plot_app?log=85c01c43-e11a-44b1-b12e-333de810dfc5) while all the states can be tracked,so I cannot find out the real reason.

It looks to me like there wasn’t enough space to actually follow that mission. I would suggest to fly a bit in stabilized first to get a feel for what sort of turns it can do, or how much space it needs. Then you can try a mission high up to see if it can track it. If not, you’d have to tune it, so that it is able to follow it. Only then I would try things like auto-takeoff and auto-landing.

thank you for your advise ,it is very helpful , I will fly it in stabilized mode to understand how it fly and then try mission mode again, further more,I would like to connect my Pixhawk4 mini to a raspberry Pi(or jetson nano) to realize some complex mission.anyway I solved my first problem ,thank you very much JuianOes hope you have a good day!

1 Like