Fatal error: Timesync_Publisher.h: No such file or directory

Hello! I am trying to set up the client side of the micrortpts_bridge (I want to use the PX4-Autopilot v1.13.3 firmware with gazebo-11 to simulate autonomous drones), and when I run the make command under this path /PX4-Autopilot/build/px4_sitl_rtps/src/modules/micrortps_bridge/micrortps_agent/build I get the following error: fatal error: Timesync_Publisher.h: No such file or directory. Below is the full terminal output of the error:
*Scanning dependencies of target micrortps_agent
[ 1%] Building CXX object CMakeFiles/micrortps_agent.dir/src/RtpsTopics.cpp.o
In file included from /home/user/PX4-Autopilot/build/px4_sitl_rtps/src/modules/micrortps_bridge/micrortps_agent/src/RtpsTopics.h:39,
from /home/user/PX4-Autopilot/build/px4_sitl_rtps/src/modules/micrortps_bridge/micrortps_agent/src/RtpsTopics.cpp:34:
/home/user/PX4-Autopilot/build/px4_sitl_rtps/src/modules/micrortps_bridge/micrortps_agent/src/microRTPS_timesync.h:46:10: fatal error: Timesync_Publisher.h: No such file or directory
46 | #include “Timesync_Publisher.h”
| ^~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [CMakeFiles/micrortps_agent.dir/build.make:63: CMakeFiles/micrortps_agent.dir/src/RtpsTopics.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:76: CMakeFiles/micrortps_agent.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
I am using ubuntu 20.04 with ROS2 Foxy to set up the simulation, if anyone knows how I can solve this error it would be greatly appreciated. Note: I already tried setting JAVA JDK from 13 to 11 in the Ubuntu.sh file from PX4-Autopilot/Tools/setup but it didn’t solve the error.

Thank you!

The RTPS stuff is changing in v1.14, so you might want to use main or the release/v1.14 branch and follow the updated docs: XRCE-DDS (PX4-FastDDS Bridge) | PX4 User Guide

Thank you for your help, I appreciate it!

I’m using v6x board with ROS2, I tried seting up MicroRTPS, but encountered this same issue. Can you kindly confirm if the release/v1.14.0-beta2 (Release v1.14.0-beta2 · PX4/PX4-Autopilot · GitHub) will work fine?
Are there any changelogs or sources to check compatibility?