Failed to simulate the path planning in Gazebo using QGround Control without the GPS signal

Dear PX4 team,
How are you?

We are a team of three University students, trying to use Aion robotics to do some research. One of our tasks is to do path planning for the UGV. We have successfully operated the real robot in “Guided” Mode in outdoor condition, and the simulation in Gazebo worked fine as well. Now we want to control the Aion Robotics in the Gazebo without receiving the GPS signal since we are not able to use the robot all the time.

We have tried to follow the steps on the PX4 User Guide. Then the r1 rover showed up in the Gazebo after we used this command “make px4_sitl gazebo_r1_rover”. However, after placing waypoints in QGround Control and letting it do the mission, the Aion Robotics rejected to be armed and started to spin on the spot. We’ve then tried other UGV, they succeeded in completing the mission. I’ve attached a link of a short video to this post to illustrate the problem. We guess the problem maybe is that Aion robotics does not work under no-GPS conditions. It could also be some issues in the differential drive modeled in the Gazebo. Could you help us figure this out?

Video Link