EKF2_EV_DELAY configuration


We use EKF2 + External Vision(Slam) quadrotor flatform, but we has a one issue.

There is always delay time MSF pose(EV) and Pixhawk local pose about 0.2s.

So, we have tried set EKF2_EV_DELAY to reduce delay time, but it doesn’t work.

Not only that, we tuned EKF2_EVP_NOISE, EKF2_TAU_POS, but anything is not affected…

How can we reduce the delay time EV and Pixhawk local pose.

Hi! Can you share the numbers you tried to set for these params and how you checked “if it worked”?

@Paul_Riseborough you might have an idea here, thanks.

Please provide a log file with logging from boot enabled. Tuning is best done using the ekf2 replay facility, but you will need a log from boot without large dropouts to do that.