EKF2 doesn't use LL40LS rangefinder

Hi everybody, I am having a problem trying to integrate lidar sensor (GARMIN LL40LS) on the Pixhawk 4.
The sensor communicates by I2C bus and I am able to see the measurement in QGroundControl, but the EKF2 altitude estimation drifts anyway.
I have tried almost every parameter combination but none of them works for me.
In my case, EKF2 still use barometer has primary source (and unique source) of hight measurement.

Is there a documented procedure to follow in order to work with such kind of sensor?

Hi @Nonn0 ,
There is documentation about range aid for the EKF2 here: https://docs.px4.io/master/en/flying/terrain_following_holding.html#range_aid
Make sure you have all the parameters properly set up. If it still doesn’t work for you, we can only give some hints if you share a log file with the issue.
Good luck.

Hi @bresch, thanks for your reply.
To the best of my knowledge, the parameters are properly set, but since it doesn’t work, I think something is still missing.
Here is a log file of a test flight: https://review.px4.io/plot_app?log=216a2be0-6655-4a49-a462-f7b03d68e036
The log file is relative to an indoor flight of my quadrotor x equipped with pixhawk 4. The PX4 software has been configured to use the IMU and the rangefinder (a Garming LIDAR-Lite v3) within the EKF2 module.

Any hints are more than welcome.
Thanks again

@Nonn0 It could be due to your sensor reporting a quality value >0 (which makes sense) while most sensors report -1 when good (but unknown) and 0 when bad. I did not check if this is is handled or not but it could be a good starting point for you.

@bresch I have just solve the problem, or at least it seems to work now.

The sensor was wrong initialised.
I initialise again the sensor with “ll40ls start…” and now the EKF2 works

Thank you very much

@Nonn0 Thanks for the investigation, I fixed the default orientation here: https://github.com/PX4/Firmware/pull/15639

Very pleased to see this. I’ve installed Lidar Lite V3 mfg’d after 2018 on I2C and while I could turn it on and off as well as see a measurement I could not modify a multiplier or voltage or user parameter ( I’m not a scripter) to get the unit to provide an accurate measurement. I’ve since installed the Benewake Mini plus with success but epuld much rather use the garmin product. I have an 11 foot wingspan UAV going into production and I’d the Garmin is prefferred. Any additional assistance appreciated and if user parameters are updated please do advise. Thank you gents for supporting an excellent product.