Does PX4 SITL work with Gazebo7 and ROS Kinetic?

Hi there,

I’ve been struggling for a while to get SITL working with Gazebo7 and ROS Kinetic installed on my Ubuntu 16.04 system and was wondering if this combination of software components is compatible at all? I have found mixed results that would indicate that some got it to work whilst others has not.
I’ve looked at the documentation at but once I run

make posix_sitl_default gazebo
I start to get some errors,

make posix_sitl_default gazebo
PX4 CONFIG: /home/mathias/Skrivebord/PX4/Firmware/build_posix_sitl_default
[ 0%] Built target prebuild_targets
[ 0%] Performing build step for ‘sitl_gazebo’
[ 1%] Built target git_gencpp
[ 1%] Built target git_genmsg
[ 1%] Built target git_uavcan
make[7]: *** No rule to make target ‘/home/mathias/Skrivebord/PX4/Firmware/Tools/sitl_gazebo/PROTOBUF_PROTOC_EXECUTABLE-NOTFOUND’, needed by ‘’. Stop.
CMakeFiles/Makefile2:215: recipe for target ‘CMakeFiles/mav_msgs.dir/all’ failed
make[6]: *** [CMakeFiles/mav_msgs.dir/all] Error 2
Makefile:149: recipe for target ‘all’ failed
make[5]: *** [all] Error 2
src/firmware/posix/CMakeFiles/sitl_gazebo.dir/build.make:110: recipe for target ‘external/Stamp/sitl_gazebo/sitl_gazebo-build’ failed
make[4]: *** [external/Stamp/sitl_gazebo/sitl_gazebo-build] Error 2
CMakeFiles/Makefile2:9035: recipe for target ‘src/firmware/posix/CMakeFiles/sitl_gazebo.dir/all’ failed
make[3]: *** [src/firmware/posix/CMakeFiles/sitl_gazebo.dir/all] Error 2
make[3]: *** Venter på uafsluttede job…
[ 1%] Built target git_mavlink
[ 2%] Built target git_matrix
[ 2%] Built target git_jmavsim
CMakeFiles/Makefile2:9909: recipe for target ‘src/firmware/posix/CMakeFiles/gazebo.dir/rule’ failed
make[2]: *** [src/firmware/posix/CMakeFiles/gazebo.dir/rule] Error 2
Makefile:3484: recipe for target ‘gazebo’ failed
make[1]: *** [gazebo] Error 2
Makefile:160: recipe for target ‘posix_sitl_default’ failed
make: *** [posix_sitl_default] Error 2

and I cant figure out how to fix these. If the combination of PX4, ROS Kinetic, Gazebo7 and 16.04 does work, is there anyone who has a link to a comprehensive guide on how to properly install and configure it?


Its all supported. You have not installed protoc. We will check the instructions, right now I assume that you skipped over the line (in the initial Linux install instructions section).

Thank you very much! That appears to have fixed the problem. I ran the scripts in the initial instructions (I anyone else stumbles upon this problem, remember to do a ‘make clean’ after installing the packages, otherwise you will still get the error).
But yes I suggest you look through the documentation. Take for example - It states explicitly that Gazebo7 is not supported.
Novice users like me, would really appreciate clear step-by-step instructions on how to get started.