Directly set PWM output values with uORB?

I’m trying to output each PWM channel from publishing to uORB topic to accomplish a certain control scheme, but by publishing to actuator_controls topic it quickly gets overwritten with 0 by another publisher. Is it possible to disable whatever is overwriting the topic, or is there another way to control each channel individually?

If you’re working on a quad and you are looking at main outputs, it should be the attitude controller that writes on actuator controls.

Please notice that these outputs are then processed by the mixer and send to actuators outputs topic before being transformed into PWM signals, so you can always disable your mixer and bypass its output by publishing on this topic for really ambitious changes on the control structure.

Thank you for your reply. How would I disable the mixer? I noticed there is a mixer file that directly passthrough each control group, but I could not figure out where to select mixers.

Also, is there a way to see where the uORB topics are updated from?

Hey @j919828, have you found any solution for this problem?