Development Toolchain installation issues

Hello there, I am following the instructions to install the development toolchain on macOS Catalina 10.15.5, it goes very well until I type the command sudo -H pip install pyserial empy toml numpy pandas jinja2 pyyaml.
Here the process moves on correctly for a while but then I get several errors, the first 3 being: ERROR: matplotlib 1.3.1 requires nose, which is not installed. ERROR: matplotlib 1.3.1 requires tornado, which is not installed. ERROR: pandas 0.24.2 has requirement numpy>=1.12.0, but you'll have numpy 1.8.0rc1 which is incompatible.

After those 3 errors, it says
Installing collected packages: pyserial, empy, toml, python-dateutil, pandas, MarkupSafe, jinja2, pyyaml Attempting uninstall: python-dateutil Found existing installation: python-dateutil 1.5 Uninstalling python-dateutil-1.5:

After that, there is an huge error message which I don’t think is opportune to paste in here… when I try to build the code for the first time, just like the instructions say, I get some FAILED messages saying I miss some components that I should install using pip3 command.

Can you tell me what should I do, please? I’m a very beginner so I’m stuck at this point with no clue of what to do :sweat_smile: thanks.

Ok, little update:

I managed to solve the first issues, I mean the nose and tornado ones, and also numpy.
But when I try to build with ‘make px4_sitl jmavsim’ I still get 4 FAILED messages, saying that “Failed to import toml: No module named toml” 3 times and then “Failed to import em: No module named em”. This is just the first of them, to give you and idea: `src/lib/mixer/MultirotorMixer/mixer_multirotor_normalized.generated.h
cd /Users/lannimatteolorenzo/Firmware/build/px4_sitl_default/src/lib/mixer/MultirotorMixer && /Library/Frameworks/Python.framework/Versions/3.8/bin/python3 /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/tools/px_generate_mixers.py --normalize -f /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/dodeca_bottom_cox.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/dodeca_top_cox.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/hex_cox.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/hex_plus.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/hex_t.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/hex_x.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/octa_cox.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/octa_cox_wide.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/octa_plus.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/octa_x.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_deadcat.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_h.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_plus.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_s250aq.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_vtail.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_wide.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_x_cw.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_x.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_x_pusher.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/quad_y.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/tri_y.toml /Users/lannimatteolorenzo/Firmware/src/lib/mixer/MultirotorMixer/geometries/twin_engine.toml -o mixer_multirotor_normalized.generated.h
Failed to import toml: No module named ‘toml’

You may need to install it using:
pip3 install --user toml`

Should I install it like my prompt say, or do something else?

ok, I finally solved by doing pip3 install toml and I did it for every module it said I was missing, they were a few.
After that I can finally build and launch a simulation with JMAVSim, but it stops at
INFO [simulator] Waiting for simulator to accept connection on TCP port 4560
And nothing happens… seems like JMAVSim is not starting, any suggestion?

sudo -H pip install pyserial empy toml numpy pandas jinja2 pyyaml .

This is from old instructions. Check the master version of the instructions:
https://dev.px4.io/master/en/setup/dev_env_mac.html#common-tools

When you see that something probably crashed higher up, so please paste the full output.

I actually solved the problem following the master version of the instruction as you suggested, thank you :slight_smile: now I’m facing the issue for which I opened the other topic, about the jMAVsim simulation window crashing.

1 Like