Detected 0 radio channels. To operate PX4, you need at least 5 channels

Hi
I used WFLY ET07, RF207S, CUAVv5 and 1.7.3 or 1.8.0, I also found this question

Hi
When should I unloose the switch? Thanks

I have the same problem, I am using 3DR PX4 with QGC and recently updated to the latest firmware suggested. I use Taranis Q X7with X8R on SBus mode. I connected properly.

The problem is whenever I use USB I can get the board connect to the RC, but if I plug in the power, the RC stops moving. Thus the calibration never get completed.
This problem persists even though I tried flashing it, factory reset or even change to mission planner.
I worry it is a hardware problem? Or may be there is something I can do to save my board?

Oh yes one thing is that this happened after I update the PX4 stack firmware. I don’t know the procedure to downgrade. Would it help?
Any help appreciated. Thanks.

Presuming the wiring is correct on both ends (GND or - on top with Pixhawk and GND pointing inward on X8R), the X8R will power up (solid green LED) when USB cable is plugged in; you don’t need a separate battery to power up. If this is not the case, your SBUS wiring is wrong, either on the Pixhawk or X8R side or both. You should be able to calibrate the Radio with just USB providing power.

Good luck.

Thanks for the quick reply.
I am sure the wiring is xorrect because qt first using usb the rc display on qgc was responding ok, but as soon as i powered or sometimes even before i powered it, it just stuck, hanged.
Also i check the X8R using a servo was working fine.

I did not separate the power to X8R. It solely powered by pixhawk.

  • Unplug the USB from FC.

  • Turn on Tx.

  • Plug battery to power to power up FC.

  • Does the X8R LED turn on solid green?

  • If it does, then plug is USB.

  • Check QGC for responses.

  • If the X8R doesn’t turn on, are you using a power module?

  • If you’re not using a PM, connect a servo cable from the FC MAIN8 port to X8R channel 8 and confirm it comes on.

  • Connect the USB and confirm QGC responses.

Good luck.

Dear rollys, thanks for the reply.

I just did what you suggested. I wonder why it was not working.
I attached link to my video.to see what I got wrong. Tx

Sorry for error upload…

I tried to what you suggested, the light is solid green but still qgc not responding. Could this be a firmware error and I should downgrade, or could it be hardware? Or something else. Tx.

Hi rollys there is a progress. I downgraded to 1.8.0 stable fw as you suggested. Thanks. It turn out that QGC displays the RC movements. But whenever I connect the power (with or without BEC power to the X8R) the QGC fails to detect the RC.
But if I connecti using USB, QGC always detects it.
It never happened before I downgraded to 1.8.0.
Did I miss something here?
May be something to do with the power module?

Hi, it seems that I still have no solution.
If I can sum up

  • Frame type Hexa
  • FC 3DR PX4 with QGC firmware
    ÷ Receiver Frsky X8R using Sbus.
    My attempts:
    -Tried X8R Sbus with USB - OK but when connect to the battery, it becames undetected.
    -Tried XRS receiver Sbus and CPPM with USB worked OK, but when I connect to battery it also became undetected.
    -Tried changing power module. Same
    -Tried using Radiolink PPM usb ok battery no.
    Anyone can help please…

Hello

I have the same problem with a Spektrum DX6i and satellite receiver used woth a Pixracer…
I plugged the three connections of the satellite in the RCIN in this order:

  • gray (signal) to RCIN (white)
  • black (GND) to black (GND)
  • orange (3.3V) to orange (3.3V)

On the RCIN port of the Pixracer, the green (RSSI) and red (5V) are left unconnected.
The satellite is binded (steady orange led), but I have the “detected 0 channels…”

Any help is appreciated!

I also have connected racer r14 to spectrum satellite with same wiring as above and always zero chanels detected untill i use usb power then all works perfect. As soon as i put it back on power module it says zero chanels detected.
I have yet to try the hold arm button method at the top of the thread.

To anyone who is having this issue after trying the flashing methods above. I second what som others have said earlier in this thread, double check that all of your wiring is correct.

I ran into this issue earlier today after removing the receiver and accidentally connecting the out cable on the Rx to the RSSI terminals rather than the SBUS. You will be able to power the Rx and bind it to the Tx while connected to RSSI, but you will receive this error when you attempt to calibrate in QGroundControl or Mission Planner. Once you connect your - + S wires from SBUS to RCIN on the Pixhawk the Radio Calibration should work perfectly the next time you try it although you may need to re bind. Binding should be near instantaneous.