Compilation for arm64/aarch64

Hello,

I am developing a product using QGC and will modify it later, but now I want to compile a normal QGC version from:

and I’m following instructions to compile
a) with docker
b) with QT installed natively.

The problem is that I’m trying to do it on an architecture described below:

Plaftofm: IMX8 cortex A53,

uname -a output:
Linux iWave-G40M 5.15.5-lts-next+gaffb3e2d0847 #1 SMP PREEMPT Tue Jul 26 09:45:54 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux

qt5.15.2: compiled from source according to:
https://wiki.qt.io/Building_Qt_5_from_Git

b)

making (make -j4) allowed me to go the same error as here:

which was:
cp: cannot stat '/opt/Qt-arm64-5.15.2/lib/libicui18n.so*': No such file or directory

I was able to overcome it by installing libicui18n.so (of some kind). It fixed the error at the end of make, but didn’t allow me to run QGC with success (the window opened, but everything was black [wayland, ubuntu 20]

But I feel like each of my solutions is a weird workaround.

a) I managed to come to same error using docker container, but didn’t manage to get past libicui problem.

I don’t really want to keep trying on this installation because tbh it feels like hell.
I want to reinstall the system (ubuntu 20) and check if the “correct way” of installing everything would work.

My question is how to setup build env for aarch64/arm64 the “correct way”?