Cannot connect MAVROS to PX4 using a LattePanda

I am trying to connect MAVROS from a lattepanda V1 to PX4 on my kakute H7. The lattepanda has ubuntu 18, ros melodic and mavros installed. I gave permission to the port sudo chmod 777 /dev/ttyACM1 (On lattepanda V1, “/dev/ttyACM0” is already taken by the embedded Arduino). Then I am able to start mavros ,

roslaunch mavros px4.launch fcu_url:="/dev/ttyACM1:57600"

And I got stuck there…

[ INFO] [1666423922.478295571]: MAVROS started. MY ID 1.240, TARGET ID 1.1

Checking the state of the connection with,

rostopic echo /mavros/state 

I am obviously not connected,

  seq: 0
    secs: 1666425230
    nsecs: 968082468
  frame_id: ''
connected: False
armed: False
guided: False
manual_input: False
mode: ''
system_status: 0

I don’t think the problem comes from the kakute neither PX4, because I can connect from my laptop with roslaunch mavros px4.launch fcu_url:="/dev/ttyACM0:57600". By the way, I already managed to connect this setup (lattepanda + kakute) through MAVROS with ardupilot. And for now I cannot connect through gpio pins because I don’t have any tension level shifter, and it should be required…

Have you tried different Baudrate? like 921600 or 115200?

Okay, it’s probably a problem of LattePanda V1 drivers… I managed to get it work by upgrading to ubuntu server 20.04.5 with ros noetic.

Yes I have tried all baudrates possible with the same value on the FC and on MAVROS but it did not work…