Why are ESCs offline?

Hi All:
I am starting to upgrade five hexacopters to v1.12.3. I ran into a new error message and can’t find out anything about it in the manual. When I power up the hexacopter, I am getting this:
“Arming denied, one or more ESCs are off-line”
What does this mean? I have connected all the ESC’s to the power distribution board and checked all the wiring several times, and everything seems OK. I disconnected all the ESCs and ran each motor individually with a servo tester and they all work. But this and other error messages are preventing me from running the motors when connected to the FC.

Also I noticed a new param PW_MAIN_OUT. This appears to be related to which channels are used to power the motors. For example, if set to 123, it will be using only channels 1, 2, and 3. The firmware was set to 12345678, meaning it was looking for 8 ESCs. Maybe that’s why the error message appears because the hex only uses 6 ESCs. However when I changed this param to 123456 and saved it, the next time I booted up the FC, it reset this param to 12345678??!! So there is some strange behavior happening, and I’m at a loss after playing with it for a day.

Any thoughts or fixes?

Thanks,
Joe

Did you resolve this query

Not yet. I’m still working on it.

Joe

For me it shows only 1 PWM_main channel which is 5 for esc motor

Still no progress with error “Arming denied, one or more ESCs are off-line”. I have been trying to change some parameters that apply to motor channels, but the firmware will NOT let me make these changes. Therefore I can’t see if this is where the problem is.

Why is the firmware denying any changes? I can’t even reset to the default.

PX4 1.12.1 feels buggy to me. Are there any fixes coming?

Joe

Hi,
I had this strange phenomena on my px4 stack CUBE orange . What I did is reset all parameters to firmware default . You need to select from parameters -----> Tools----> firmware default settings. Then reboot the flight controller.