Strange issues with Internal mag

Hi all!

I really resisted asking for a long time as I tried a lot on my own without results.

Simply I am having huge issues with the inbuilt magnetometer of the newly purchased pixhawk 2.4.8. No external compass is used. Only want to disable the internal one, is it even possible? Why disable ??:

Well, after many repeated successful, firmware updates, sensor/esc calibrations and successful arming…, the multirotor motors spin, and pitch/roll/yaw inputs respond correctly BUT STRANGELY each input ALSO results in a residual respond:
if I input pitch, pitch responds but also a little roll responds as well..

When compass is disabled in parameters in QGC CAL_MAG0_EN = disabled pitch command results only in pitch respond etc…!! good!

However, after disabling the MAG0 , the pixhawk gets all sorts of random issues. sometimes it works fine, other times it wont arm, and if it arms, the motors spin without responding to commands at all…
Right now the motors spins upon arming but zero response from Tx

If I re enable CAL_MAG0_EN = enabled- everything turns back Ok but with the original issue: that pitch command results in 80% pitch and a little roll. and vice versa…

How do I attack this issue as it is honestly very frustrating, Can I even disable the internal only internal mag w/o problems or should keep it on?

Best regards

I received an external GPS/Compass. Disabled the internal one, redone all updates and calibrations. Still the same problem: ie: the pitch/roll are coupled upon input of either roll or pitch. Frame tested is a Quad + .

Any help is very appreciated!