[SOLVED] FrSKY Taranis X9D Plus and X8R Telemetry Lost Problem


I’m using FrSKY Taranis X9D Plus with X8R receiver. After resetting the transmitter, I have completed Stick calibration and configured Fail-safe.

I created a model for Fixed-wing and bonded X8R successfully.

But the problem is that now when I’m using the TX-RX, several times the TX announces that Critical range problem and Telemetry signal lost. After a matter of seconds, it will connect again.

This issue repeats again and again. I don’t know what and where I missed.

I cannot test my flight in this condition.

I’m new to FrSKY Taranis and X9D.

Anyone faced similar problem and If solved, please share the solution (troubleshoot or setting problem).

1 Like

The Tx is probably swamping the Rx. Try moving the Tx a few feet away and see if it stops.

Good luck.

I even tried 3 meter distance from the receiver. Still the same problem.

I have erased by EEPROM and did stick calibration and set Receiver Failsafe option for my model.

After that I bound X8R successfully using SBUS and D16 setup with channels 1 to 16.

Did I missed any first time configuration??

You might be better served going to the RCGroups forum on this since it may have nothing to do with PX4 at the moment.

Good luck.

This problem is automatically solved.