Skydroid 16H Pro can't connect through receiver h16 to Pixhawk 6x

Using the connection UDP on port 14551, the QgroundControl remain disconnected from the Pixhawk 6x when using the h16 (30Km receiver), but using the Sik radio all is OK.
When oppening the QgroundControl app. the error is : "Error binding the UDP port: The bound address is already in use "
I use pixhawk 6x with latest firmware (1.14)

Can anyone help me.

Thanks !

If you have binded the air unit and handheld and following the instructions it should work fine. The udp port number for uart 0 is 14551 make sure to connect it to the correct uart port. If you still have issues then reply here

Yes I configured port and and insert cable to uart0 of the receiver as you say the problem remain.
But trying to solve something, I start a firmware update from H16Tool /Advanced settings, this update work since 2hours and didn’t stop, even if I stop the Skydroid tablet, the update doesn’t finish ever, did you know what firmware refer to, the H16Tool ?. After powering off the skydroid tablet it start automatically flickering continously the the ABCDEF switches lights.

I solved the problem with Firmware update in H16Tool app, and now the Skydroid H 16 work Ok, but If someone can tell me what firmware was updated from v1.2 to v1.3, the only information that I find H16Tool is : “Local firmware”.

The connection problem remain, when start the QGC I receive the error: "Error binding the UDP port: The bound address is already in use ".

Well the new pro units also had asked for firmware update I did them with no problem. But their technical support sucks, I can’t reach them anyway. A bit dumb question but do you manually choose to connect on the qgc comm links tab? the message you get is usual and doesn’t cause any problems for me

Yes I do the connection from Connect button from Comm Links but QGC remain Disconnected.
Did you check/uncheck the UDP check box in ApplicationSettings/General menu?

I am not sure, but that shouldn’t cause any problems. This seems weird, can you post some pictures and screenshots from your setup?

Sure, but I’ll send you these pictures Monday, I have some family health problems now. Thank you !

no problems, take care

I also have the same problem: Skydroid H16 does not transmit complete measurement data. What is the solution?

Sorry for late reply, yesterday I found that H16Tool after Local firmware update doesn’t work correct so the configuration file for this Tool is missing, also the Save an Read commands do not work. The message "Error binding the UDP port: The bound address is already in use " when opening QGC is present.
More than that, when Receiver H16 is disconnected from power, when start QGC from Skydroid H16 the same Error is present. I conclude that is a problem with OS or application, somehow the port remain in use (locked) even if Skydroid H16 is switched Off (PowerOff). I decide to make A firmware upgrade for Skydroid 16H using this link : “https://www.youtube.com/watch?v=RxYOF9iJd2w&ab_channel=StoneWhite
At the end of the upgrade the Skydroid H16 did not rebooted and now I have black screen no lights and no buttons, it appear to be dead. So I can’t send you any screen shots with settings or pictures, I write to HolyBro to help me.
If it is useful I have the log for the upgrade.

Microsoft Windows [Version 10.0.18363.836]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>cd C:
C:\Windows\System32

C:\WINDOWS\system32>C:

C:\WINDOWS\system32>cd …

C:\Windows>cd …

C:>cd adb

C:\adb>flash_all.bat
236c954a fastboot
arowana-rc
Erasing ‘logo’ OKAY [ 0.039s]
Finished. Total time: 0.039s
Sending ‘logo’ (4500 KB) OKAY [ 0.101s]
Writing ‘logo’ OKAY [ 0.147s]
Finished. Total time: 0.290s
Sending ‘oem’ (16761 KB) OKAY [ 0.367s]
Writing ‘oem’ OKAY [ 9.734s]
Finished. Total time: 10.173s
Sending ‘boot’ (24492 KB) OKAY [ 0.554s]
Writing ‘boot’ OKAY [ 0.769s]
Finished. Total time: 1.439s
Sending sparse ‘system’ 1/20 (55197 KB) OKAY [ 1.274s]
Writing ‘system’ OKAY [ 1.832s]
Sending sparse ‘system’ 2/20 (56378 KB) OKAY [ 1.321s]
Writing ‘system’ OKAY [ 1.944s]
Sending sparse ‘system’ 3/20 (57340 KB) OKAY [ 1.335s]
Writing ‘system’ OKAY [ 2.008s]
Sending sparse ‘system’ 4/20 (57340 KB) OKAY [ 1.293s]
Writing ‘system’ OKAY [ 1.804s]
Sending sparse ‘system’ 5/20 (57322 KB) OKAY [ 1.342s]
Writing ‘system’ OKAY [ 2.035s]
Sending sparse ‘system’ 6/20 (57342 KB) OKAY [ 1.359s]
Writing ‘system’ OKAY [ 2.071s]
Sending sparse ‘system’ 7/20 (57104 KB) OKAY [ 1.303s]
Writing ‘system’ OKAY [ 1.894s]
Sending sparse ‘system’ 8/20 (52268 KB) OKAY [ 1.289s]
Writing ‘system’ OKAY [ 2.236s]
Sending sparse ‘system’ 9/20 (52848 KB) OKAY [ 1.203s]
Writing ‘system’ OKAY [ 1.721s]
Sending sparse ‘system’ 10/20 (57090 KB) OKAY [ 1.360s]
Writing ‘system’ OKAY [ 2.074s]
Sending sparse ‘system’ 11/20 (57341 KB) OKAY [ 1.316s]
Writing ‘system’ OKAY [ 2.027s]
Sending sparse ‘system’ 12/20 (57106 KB) OKAY [ 1.334s]
Writing ‘system’ OKAY [ 2.066s]
Sending sparse ‘system’ 13/20 (57340 KB) OKAY [ 1.320s]
Writing ‘system’ OKAY [ 1.833s]
Sending sparse ‘system’ 14/20 (57227 KB) OKAY [ 1.355s]
Writing ‘system’ OKAY [ 2.051s]
Sending sparse ‘system’ 15/20 (57129 KB) OKAY [ 1.424s]
Writing ‘system’ OKAY [ 2.490s]
Sending sparse ‘system’ 16/20 (57202 KB) OKAY [ 1.362s]
Writing ‘system’ OKAY [ 2.212s]
Sending sparse ‘system’ 17/20 (55136 KB) OKAY [ 1.324s]
Writing ‘system’ OKAY [ 1.990s]
Sending sparse ‘system’ 18/20 (56274 KB) OKAY [ 1.322s]
Writing ‘system’ OKAY [ 2.060s]
Sending sparse ‘system’ 19/20 (50458 KB) OKAY [ 1.193s]
Writing ‘system’ OKAY [ 1.817s]
Sending sparse ‘system’ 20/20 (24809 KB) OKAY [ 0.579s]
Writing ‘system’ OKAY [ 0.885s]
Finished. Total time: 67.453s
Sending ‘userdata’ (23569 KB) OKAY [ 0.517s]
Writing ‘userdata’ OKAY [ 0.787s]
Finished. Total time: 1.406s
Sending ‘recovery’ (28484 KB) OKAY [ 0.627s]
Writing ‘recovery’ OKAY [ 0.878s]
Finished. Total time: 1.640s
Sending ‘cache’ (6248 KB) OKAY [ 0.141s]
Writing ‘cache’ OKAY [ 0.210s]
Finished. Total time: 0.402s
Sending ‘misc’ (8 KB) OKAY [ 0.000s]
Writing ‘misc’ OKAY [ 0.000s]
Finished. Total time: 0.038s
Sending ‘firstboot’ (300 KB) OKAY [ 0.016s]
Writing ‘firstboot’ OKAY [ 0.022s]
Finished. Total time: 0.069s
Sending ‘trustzone’ (456 KB) OKAY [ 0.016s]
Writing ‘trustzone’ OKAY [ 0.038s]
Finished. Total time: 0.069s
Sending ‘secondboot’ (1004 KB) OKAY [ 0.016s]
Writing ‘secondboot’ OKAY [ 0.038s]
Finished. Total time: 0.100s
Rebooting OKAY [ 0.000s]
Finished. Total time: 0.016s

That’s a bummer. I haven’t had a experience with that kind of system upgrade. Seems like you bricked your unit. I hope Holybro can help you. I also have a problem with the h16 right now and trying to reach sykdroid with the help of 3dxr. Good luck!!

I found the reason for initial problem of missing connection between Flight controller and Skydroid H16 pro QGC (telemetry), it was the wrong cable supplied in the H16 -pro Kit (H16 Receiver UART0 and TELEM1 of the flight controller) by Holybro, the cable match by mechanical , color and form, but electrical the wires connections are not correct. Now, until I’ll have the Skydroid H16 functional I can’t try anything , but is very clear this cable is not the right cable, until now I didn’t receive any response from Holybro or Skydroid regarding the tablet restarting.

Good that you located the problem. If you get anything back from them please reply here so I would know if I also should wait for response or not.