SITL Installation without Homebrew

Hey, so I wish to install a simulator (jMavSim or Gazebo simulation) on my macOS Catalina Macbook to run with QGroundControl. But unfortunately, you require Homebrew to install the simulation prerequisites, and I can’t install Homebrew on my MacBook because Catalina deems it too dangerous.
(“Running Homebrew as root is extremely dangerous and no longer supported”). And after browsing through a lot of forums, I would like to stay away from it as well.

I have Macports installed, and tried using that but it doesn’t work.

port tap PX4/px4
Error: Unrecognized action "port tap"

Can anyone help me out? Is there any way I can install without Homebrew? Or use another simulator?

I’m linking the page I followed for the instruction process.
Simulation Prereqs install for macOS

Thanks in advance!

I’m confused. I’m using homebrew on Catalina just fine.

And using something like port would probably have the same security risks since it’s a similar concept but I believe less used.

“Running Homebrew as root is extremely dangerous and no longer supported

I think the issue here is that you’re using sudo.

Hey, so I tried installing Homebrew for Catalina again and it worked! And I’ll keep in mind about using sudo. I think there are some permission issues. Thanks a lot!


1 Like