Same hardware, same MC parameters, but significantly different vibrations in hover - Where does this come from?

Hello everyone,

I recently had to upgrade from firmware version v1.10 to v1.14. I did not make any changes to the hardware (Holybro QAV250, Pixhawk 4 Mini), all the MC-* PID parameters are equal in both versions.

Nevertheless, the drone oscillates visibly more in hover flight with v1.14. This can also be seen in the Acceleration Power Spectral Density as dominant frequencies are much lower, and is clearly reflected in the power consumption, which increases considerably because of this; mean and variance of battery current are a lot higher in v1.14. Unfortunately, I can’t share the flight logs but here are the relevant plots:

I already had a similar problem with the v1.14beta2 version, as accel clipping occurred there. This no longer seems to be a problem with the stable release, but the vibrations are still very different. Tips for troubleshooting vibration issues usually refer to modifications to the hardware setup or the PID parameters, but these obviously cannot be the cause as there are no changes of those when flying with the two different versions.

I can’t work out why there is such a significant difference in the vibrations with the same hardware setup and controller parameters for the hover.

Why are the vibrations so different just by using a different firmware? What parameters can I adapt to reduce these vibrations and thus the power consumption?

Many thanks for your help!

The vibrations might “look different” because the sensor pipeline has changed and likely does less filtering by default.

If you have high vibrations (but no clipping!) then you can try to use the notch filters:

I set the IMU_GYRO_CUTOFF parameter from 120 to 30, and the IMU_DGYRO_CUTOFF from 45 to 30. This has reduced power consumption similar to the previous level. Unfortunately, with this new setting, an accelerometer clipping occurred. Could reducing IMU_ACCEL_CUTOFF maybe help here?

Clipping is a hardware problem and means the actual vibrations are too high for the sensor. No filtering in software will fix this problem. You need to reduce vibrations (e.g. balanced prop, better frame, whatever) or use vibration isolation when mounting the flight controller. Is it currently hard-mounted or on foam or at least double sided tape?

Currently I have the flight controller only mounted on a (fairly thick and soft) double sided tape, but have foam available. I will check what else I can change on the setup to reduce vibrations, thanks a lot for your advice!
It’s still a bit confusing as clipping never occurred when flying on v1.10 before, so for me it still seems to be related to a change in flight behavior after updating to v1.14 which results in stronger vibrations.

Clipping likely occurred but wasn’t logged. Or maybe tuning was sufficiently different not to excite it.