QGroundControl: How to Spektrum Bind when connected to Pixhawk

#21

Try this:

  • Unplug the AR610.
  • Swap the Yellow and Red wires of the Satellite on the Pixhawk side and see if the satellite lights up.

if nothing else works, you might have to get with HolyBro.

Good luck.

1 Like
#22

Thanks for the advice, switching the red and yellow wires did the trick! The satellite receiver turned on and I was able to bind it to QGC, and I can finally move forward with this project. Thank goodness you guys are here. :wink:

However, I did soon run into another error - when trying to do the radio calibration, I cannot correctly assign the yaw and roll sticks - whenever I move the yaw stick to the location that is prompted (on Mode 2), nothing registers. The calibration only accepts it if I use the right-hand stick, which shouldn’t be used for yaw. Do you know what might be going on?

1 Like
#23

I use a Taranis QX7 so it’s easy for me to move my channels as needed in the Tx. I’m presuming you’re using a Spektrum Tx so, I’m not sure but check your params; mine are as follows:

RC_MAP_ROLL 1
RC_MAP_PITCH 2
RC_MAP_THROTTLE 3
RC_MAP_YAW 4

If yours are different, make note of them first then maybe change them to like mine, powercycle then see if they are corrected from there and calibrate completely.

Good luck.

#24

Thanks again, that worked for me. For anyone who might be reading this in the future, the way to change the channels on the Spektrum DX6e is to go to the System Setup option, then Channel Assign.

I was also able to do all of the calibrations except for the airspeed one, do I need to have one of those before I can set flight modes?

#25

No.

Glad everything is working out.

Good luck.

#26

QGC isn’t letting me set up Flight Modes because the Sensors aren’t all calibrated, and all I have left to calibrate is the Airspeed control. How then do I set up Flight Modes?

#27

You can temporarily disable the airspeed sensor check CBRK_AIRSPD_CHK to 162128 in Parameters then power cycle.

Good luck.

#28

Thanks, rollys. Your advice has helped me big time. I don’t have any other problems at the moment, so hopefully I’ll be getting my plane up in the sky soon.

#29

Hi Everyone,

Has anyone used a pixhawk mini with QGC and a Dragonlink system?

I’m having issues with getting the QGC to connect “Find” the vehicle (pixhawk mini) via the Dragonlink (which is connected to a DX9 transmitter).

Any help would be appreciated.