QGroundControl bug (2 found)

I am just reporting two bugs I see quite often just in case its not reported. If its been reported, ignore this post and close it. I ONLY use QGC and not MP as I find QGC is flawless.

First bug is to see the “Heli” options I must first connect the USB to PIXHAWK, then open QGroundControl, then wait for it to load (connect), then after connected, immediately close GQC and re-open it (still connected, thats the critical step, you MUST remain connected to the PIXHAWK and PC). This is the only way it seems to load the Heli options, if I do it out of order, heli options are blank and wont show (of course the full params works but I like the heli view). This is not a 1 time issue, this happens EVERY time I load QGC and connect my bird to see the Heli options.

Before re-loading QGC:

After re-loading QGC (still connected to USB):

Second bug is every time I download logs from QGC to my PC, GPS goes crazy and glitches, EKF goes crazy and flips between the EKF primary/secondary back and forth, back and forth. The second I finish the log download, GPS glitch clears, EKF settles and all issues go away. This is not a 1 time thing either, this happens EVERY single time I download logs from PIXHAWK through QGC.

Neither bug really affects anything and I am completely able to do what I need to do with QGC but its annoying and could pose issues for others so I wanted to raise it so others see it and know why the heli options may not be showing first time its connected and QGC loaded. This is why, simply close/open QGC while still USB connected to PC and PIXHAWK and will show up.

Another really annoying thing that’s been discussed before (other forums but I dont see a solution) is VOLUME and audio reporting with no options to stop. Why is there no way to disable the audio output or at least a volume slider? Its difficult to work on my helis and do anything else when the voice keeps popping up. I know, I know, I get it, my collective is below fail-safe, I am on the bench, not trying to arm so I dont care not need to be reminded every 5 seconds. If I lower my laptop volume, then I cant hear my meetings, conference calls (VoIP), ETC so I must keep volume enabled on Laptop.

ArduPilot bug: https://github.com/ArduPilot/ardupilot/issues/11591. Fixed in master ArduCopter builds.

I would file an ArduPilot bug against that.

You can turn off speech output from the General page of Application Settings: “Mute all audio output”.

WOW, I swear to you, I looked EVERYWHERE for that dang mute option, THANK YOU! Also thank you for the info on the bug, I will keep an eye out for the update/fix in future releases, again, thank you! I will also post to the bug in ArduPilot, thanks again!

Also thanks for the problem reports (even if they aren’t really QGC related). I can’t make things better without knowing what the problems are.

NP, I am a HUGE fan of PIXHAWK, I have been an open source developer since I could walk (mainly Linux) so when I found the PIXHAWK, and open source FC, I was in Heaven! This is an amazing community, providing amazing software support (QGC) and the FC open source platform. I am astounded how well this works on my TRex 600 and collective pitch UAV (I am even contemplating adding one into my TRex 700 HV). I will do whatever I can to help the community or support the platform!