QGC Compatibility with MAC OS

Hi. I am new to this forum so please excuse and advise me is this should be post elsewhere on an existing thread.

Moving on swiftly…

The installation instructions for the MAC Download indicate that it is compatible with OS X 10.8 and later

I am running OS X 10.10. 5 and when I follow the installation instructions the process fails and creates a crash report. Inspection of the crash report show the following section

Dyld Error Message:
Symbol not found: __os_log_default
Referenced from: /Applications/QGroundControl.app/Contents/MacOS/…/Frameworks/QtCore.framework/Versions/5/QtCore (which was built for Mac OS X 10.11)
Expected in: /usr/lib/libSystem.B.dylib
in /Applications/QGroundControl.app/Contents/MacOS/…/Frameworks/QtCore.framework/Versions/5/QtCore

This would seem to suggest that QGC will not run on my MAC after all as it was built for OS X 10.11, not 10.8

Please could someone confirm this, and if possible suggest a solution, and possibly also correct the download page information

Many thanks

AK7466