PX4 Cygwin with CodeBlocks development

Hello, guys. In PX4 building code-manuals I read that we can make firmware using command, like:

cmake ../Firmware -G "CodeBlocks - Unix Makefiles"

And I thought - “CodeBlocks IDE… Why not?” That I prefer it more than QT in work. I tried to build CodeBlocks-project for target on Nuttx using:

cmake ./Firmware -G "CodeBlocks - Ninja"

This command generated project (*.cbp file in built directory) for CodeBlocks IDE for Nuttx-based target. And I’m able to load it in IDE and built without any mistakes (as “out of box”. You only need to set up Debugger and Compiler options in IDE).
It works fine all… but in Ubuntu.
And… I dont like Ubuntu (Unfortunately I think that Linux-desktop is rather dead than alive (less than 1% users). ) I tried to repeat all steps in Windows (with Cygwin). And ran into a problem… - paths defined by Cygwin.
When I try built a project, I get errors, such as:

The file does not exist.

It clear, that Cygwin area uses own link to the root directory, as ‘cygdrive’, and system cannot set valid path to source-files (hence - Error: Could not open file. No such file or directory).
System tries to get path through “\cygdrive\c” that causes problem.
How fix it?? I found any topics in web, but still I cannot to solve this problem.