Problem with the FCU connection


We have built a simulation for autonomous underwater vehicle build on the PX4 Firmware last year. To start the simulation we sourced

source ~/git/Firmware/integrationtests/setup_gazebo_ros.bash ~/git/Firmware

and then launch

roslaunch px4 hippocampus.launch

Due to changes in the PX4 Firmware the setup_gazebo_ros.bash has been removed. I tried just to add the file again in my own forked repository to enable the simulation but I got the error:

Mode: Unconnected FCU

A short diagnostic run showed that the FCU has been unconnected. Thus I tried the new source strategy

cd <Firmware_clone>
make posix_sitl_default gazebo
source ~/catkin_ws/devel/setup.bash // (optional)
source Tools/setup_gazebo.bash $(pwd) $(pwd)/build_posix_sitl_default
export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:$(pwd)/Tools/sitl_gazebo
roslaunch px4 hippocampus.launch

which leads then to a connected FCU but results in an error message when starting additional ros nodes to interact with mavros

Rejecting arming cmd

Does anyone has any idea how I can fix this?

Best regards