(Pixhawk) Not able to select frame or calibrate sensors | missing parameters error

Hey there,

I am facing a problem which I was not able to solve so far:

I am using an ‘old’ pixhawk which was programmed by Matlab/Simulink (px4 support package) the last 5 years without any problems. Using the latest version of the support package lead to the problem, that the software is running, but the sensor block won’t provide any data.

Therefore I tried to flash the default software using QGroundControl to setup the frame and to calibrate the sensors (sd card removed). But here are the next problems: After flashing the stable v1.13.0, QGroundControl is showing up these error messages:

Addtionally, I am not able to set the airframe as there is no content on this page:

I tried to reset all parameters which didn’t help. I also tried (much) older versions but was allway facing the problem, that I cannot select the airframe. In some cases I could select the airframe but the sensors page was blank as well. I even installed the exact firmware version which is support by Matlab/Simulink (1.10.2) and the corresponding QGroundControl.

I tried to install ArduCopter which worked wihtout any problems, even the sensors are working there.

What’s the problem here? Do you have any ideas?