Pixhawk-Mini px4 v1.8.2: Preflight Fail - No Mag Sensor 0

#1

Hello gentlemen,

I have encountered a roadblock in the process of setting up a 3DR pixhawk mini. Unfortunately for myself, all but one of the accompanying GPS/compass that came together with the FCUs are giving me the same error. To sum it up, the GPS readings are working fine on all modules, however the HMC5883L digital compasses are not being recognised by the FCUs.

One of the GPS/Compass units were working fine however and it was able to be used on the rest of the pixhawk minis, hence I can at least eliminate the FCUs being faulty. I also understand the mpu9250 internal mag drivers have been disabled so they are not being utilised, the point being I am unable to get the external compasses to be recognised.

When I manually input commands on the mavlink console via ‘hmc5883 -X start’, this would be the outcome:
WARN [hmc5883] no device on bus 1 (type 2).
Similarly, ‘listener sensor_mag’ gives off - ‘never published’

I went and bought the Ublox micro m8n gps/compass modules as I suspected an initial hardware error with the compass however the same error occurred yet again. Thus, I have decided to consult your team for advice to understand and hopefully, rectify this issue. Thanks in advance!

Source:

         https://cdn-global-hk.hobbyking.com/media/file/m/i/micro_m8n_manual_v1.0.pdf (pinout for gps/compass 
         module)
         
         https://cdn-shop.adafruit.com/datasheets/HMC5883L_3-Axis_Digital_Compass_IC.pdf (HMC5883L pinout)
         
         https://hobbyking.com/en_us/pixfalcon-micro-px4-autopilot-plus-micro-m8n-gps-and-mega-pbd-power- 
         module.html (pixhawk minis I bought)
         
         https://hobbyking.com/en_us/ublox-micro-m8n-gps-compass-module-1pc.html (the new gps/compass modules)
#2

Have you tried if the issue is the same with master (1.9.0)?

#3

Sorry, but I was not too keen on trying out the beta if the stable versions are available. At this rate I might as well give it a go.

1 Like
#4

Hello,
I have the same problem.
Preflight Fail - No Mag Sensors PX4 v1.8.2

#5

Could you try master please and see if the issue persists?

#6

I have tried out the current master of 1.9.0 and the qmc5883 drivers are working well. May I ask if there is any way to bring it over to 1.8.2?

#7

There have been many improvements with 1.9.0 especially for newer boards such as Pixhawk 4, so I recommend to switch to 1.9.0 especially since it will be released soon.

If you want to backport you’ll have to try to do that yourself, we don’t have the developer bandwidth to do that.

#8

Hey thanks for the help and swift replies Julian! I will test out 1.9.0 in flight soon as well, so hope everything checks out fine.

1 Like