Pixhawk 4 mini not powering motors

I’ve got a pixhawk mini 4 using mission planner. Went through the setup and calibration. It powers up and will connect with mission planner (via usb). I force arm in MP but when I throttle up the motors wont turn. I must be missing a step(s).

Seeing 3 lights:

  • Power: Solid green
  • B/E: Flashing red (2 flashes)
  • ACT: Rapid flashing blue (17ish flashes)

I scoured YouTube for tutorials but all are on Pixhawk (not mini). Any setup documentation, videos or troubleshooting tips would be greatly appreciated.


Safety switch is probably enabled but either not pressed or not fitted. For help with Missionplanner and ArduPilot, better to head over to discuss.ardupilot.org

Thanks. Where does the safety switch plugin on the 4 mini? Is it the port on the side next to the USB? Is the switch purchased separately, seems like something that should be included?

I see the switch is on the GPS unit. How long should it be held for to arm?

About 2sec, but it should beep

Thanks, Tried that, still no power to the motors.

Is there a comprehensive tutorial on youtube that folks are using? Feel like i’m piecing together info to stumble through setup, but imagine there is a tutorial somewhere?

Setup varies a lot depending on which firmware you’re using. You mentioned Missionplanner, so I’m guessing you’re using ArduPilot firmware?

Thats correct. Flashed it twice with ArduPilot just to be sure.

The forum for ArduPilot is discuss.ardupilot.org (I know this gets confusing for people starting out).

Docs here: https://ardupilot.org/copter/docs/initial-setup.html

1 Like

@auturgy Awesome, thank you


@auturgy Getting this message. Wasnt able to find the solution online.

Thank You for docs! !

Really need to take it to discuss.ardupilot.org