Parameter screen casts floats as ints

A large number of parameters, including cal coefficients, show on QGC as rounded to nearest integer. If I save params to a file, or do param show PARAM in a Mavlink console, I see the full floating point values. Any suggestions on why this would be?

I’m running PX4 1.12 and QGC 4.2.8 on Ubuntu20.

Have you checked whether this has been fixed in the latest QGC version? Oh nevermind, that’s what you’re using.

Have you tried with a newer version of PX4? I wonder if it’s due to the parameter meta data coming from the flight controller.

Yes, I’ve tried the latest stable PX4 and the same behavior is happening. I also cleared the folders under ~/.cache and ~/.config but no change. Thank you for the help.

Not sure if that’s it, but I noticed that after I add my own parameters such as in snippet below, then QGround shows param as integer, but logging param value from module still shows floating point exact value.

 * My coefficient
 * @group My Group

However if I add * @decimal 7 to description of param, then QGC shows param properly and can be changed to floating point without issues. Note that you may not need 7 decimal places and can specify custom value.

Worth to mention, I work on PX4 version: 1.14.0 0 (17694720) and QGC daily, master: 2023-01-11.