Martyrdom history about GPS Here CAN connection with PixRacer

Good day, friends!
One fine day, i want to connect my PixRacer with GPS Here 2, using CAN bus.
I know, what with pixhawk 2.1 this solution is worked.
There is one CAN connector in the board.
After connection, uavcan status said: Node id:125 status: maint.

Then I began to search problem in code.
PixRacer has FMUv4, pixhawk2.1 - FMUv3.
Code for initializing CAN is identical.
I looked with logic analyzer on CAN-outs of PixRacer and outs of HERE,
RixRacer sent requests, but GPS Here sent zeros.
Then I made out HERE, and looked for availability CAN module.
I knew, what GPS HERE 2 rev 1 doesn’t work with CAN bus well, and specially ordered HERE 2 rev 2.
But i faced with obstacle. This is my first module:

On one side of module is written by white color ‘REV 2’, on another side by engraving - ‘R1’.
I bought new module of GPS. And made out for turn jumper from i2c to CAN. And what i saw!?

On both sides REV2 is marked! And there is another module YF08E.
Now this work fine.
Has anyone encountered such a problem related to GPS HERE module revision and CAN compatible?
Good luck everyone!

I have never successfully got CAN GPS units to work within PX4, however their is a trend to move GPS units to can.

For me, tried HereFlow which works perfect with X2.1-777 as flow and range sensor up to 2m. But it doesn´t work at all with two different Pixracers. First i thought that some pins were exchanged in the “china style” PicRacer but at the end I ordered a second R15 one directly from MRO with the same result.
Finally I don´t understand could it be a hardware issue cause the can pins CL and CH are really exchanged between x2.1-777 and PixRacer shown in the circuit diagram.

Mostly it´s only a ram overflow cause UAVCAN needs lots of ram.
Swiching off some mavlink instances solved it for me e.g. serdis to remove the USB connection. If not needed the autostart of the WIFI telemetry has to be removed.