Link 1 down while connecting Orange PI to Pixhawk

Hi everyone, I’m trying to connect my Orange PI 3 to Pixhawk with telemetry. I make the connection below:

I also enable the uart from the config file according to user mauel of the Orange PI and my UART3 port is active:

When I run “” in the command line I’m getting the output below:

Auto-detected serial ports are:

Only the ttyS0 and ttyS3 active among them. ttyS0 is the three port you can see in the pinout. ttyS3 is the ports that I connected.

My connections are true, I even tried to switch TX and RX, I also tried different baud rates (57600, 921600) but whatever combination I tried, I always get the MAV> link 1 down output from the mavproxy.

Am I missing something? I can connect raspberry to the pixhawk with same configuration.

Note: I completed all the steps in the links below
Download and Installation — MAVProxy documentation 1
Communicating with Raspberry Pi via MAVLink — Dev documentation 1

I also tried to connect it with USB-UART but same thing happened.

You might want to ask in instead for questions with MAVProxy.