HoTT telemetry integration

Hi everybody,
I am trying to send the telemetry data to a HoTT GR-16 receiver.
In the firmware I have activated Hott_telemetry and deactivated frsky_telemetry.
The recompiled firmware is watched by a connection through the USB-port (without a SD-card)
I start the telemetry with “hott_telemetry start -d /dev/ttyS2” because I am using serial5 (which is also the port for the systemconsole).
I got a long list of messages “OK” and “syncing” in the nsh terminal . The list is filled even if the connection to HoTT is cut. It seems as if some traffic is on the COM-Port from inside.
It seems strange to me the the Port serial5 is used by the systemconsole and by the telemetry.
Who can help?

@sjwilks Can we move the discussion on HoTT here? We’re de-activating the old mailing list and this is the new best forum for HoTT.

It seems not to be a HoTT problem.
I have continued my trials and found out, that there is traffic on serial5 even if there is no HoTT receiver connected. I tried with an LED and a resistor, the LED is lighting on Rx and un Tx cannel of serial5. I suppose that both levels should be on low, if no traffic is on it.
So I suppose that some app is using the serial5. But what app?
I have no logic analyser and my test with a 3.3V/5V converter and a second PC gave no readable signal.
So perhaps an oscilloscope can show me whats going on. I will try to get one.

Just to be sure: Are you using Pixhawk? Are you using the pins 4 and 5 of the SERIAL4/5 connector? In that case this would be the debug console and you cannot use that port. If you use pins 2 and 3 there should be nothing on them by default.

Hi Lorenz,
thank you to your reply.
I use now the pin2 which is connected to Serial4 and changed the default to UART8.
There was still the app sf0x disturbing which also uses serial4. I have disabled it and recompiled the code. Then it works!!

There is still something to change in the manual:

  1. In the video they use the pin4 with the pixhawk.
  2. there should be a hint of sf0x
  3. there should be a hint that the module hott_telemetry is not included by default, but frsky_telemetry which will also disturb the hott-telemetry.

Finally it works!!!
Thank you.

Hi Holger,

I gave this a go today. At least in my case communication doesn’t start working properly if the RC is turned on first so I had to start the hott driver and then turn on RC. This isn’t the way it should be. Can you confirm it works with the RC on first in your case?

I’ll update the code to use Serial4 as the default now that the V1 boards are more or less gone and do a bit of a cleanup.

I’ll also update the docs but the sf0x should only interrupt if you enable the SENS_EN_SF0X parameter which defaults to off.


Seems to work better for me now after a bunch of improvements. I’ll get a PR out tonight with the changes so you can try it out.

Thanks for the PR! It has been merged to master. I would love to hear about testing feedback.

Hi Holger,
I’m also trying to get HoTT working for a while now, but still no success.
(Pixhawk hardware)
What I’ve done so far:

  • uncommented the two lines in nuttx_px4fmu-v2_default.cmake
    –> can start hott_telemetry in console now
  • connected “T”-pin of GR-24 -receiver to Pin2 of SERIAL4/5 connector
    (should be UART5 (/dev/ttyS2)) ???, but tried other ttySx also…
    (RC system has recent firmware, so probably using the “fast” HoTT-protocol)
    –> hott_telemetry start -d /dev/ttyS2
  • hott_telemetry stays in state “syncing…” forever, no sensors will be visible on transmitter (mx-20)
  • if I measure the serial wire by scope, I can see the requests coming from the receiver, but no reply from Pixhawk.
  • also tried switching on the equipment in different orders, no difference
    Could you please give a hint what else I should try?

regards, Boris

Hi Boris,

I’ll need to try this out with the latest firmware. I wasn’t aware of a change in the HoTT protocol so that could be an issue.

If you are using the latest master (after my code went in) you shouldn’t get the stream of “syncing” messages. Once the driver is running you can try running hott_telemetry status which should give you more detailed stats.

Also, when using Serial 4/5 it will use /dev/ttyS6 which is the default in my latest changes.


Hi Simon,

ok, it was my fault, always tried with ttyS2/3…
(btw, is there a valid list to which ttySx all the UARTs of Pixhawk hardware are mapped? )
now trying with ttyS6 and it works, so the Hott-protocol should be fine!
I don’t see any interferences with sf0x and frsky telemetry as mentioned in annother post so far, so I haven’t disabled anything in code. Right now I’m using 1.4.1rc4, because when trying the newest master it complains about invalid sensor calibration/not working sensors, so nothing I can use right now.
What I’m missing in telemetry data are most of the battery-related values! (only battery voltage is shown, no current, no remaining capacity/percentage…) Could you please make these available, as this is what I’m mainly interested in when using telemetry. (flying with different payloads, so remaining flight-time is difficult to guess)

Thanks in advance, Boris