For users having trouble setting up Intellisnse on Windows OS : Look here



I have recently encountered this problem (Intellisense not working properly, meaning even when I press F12 which is “find all references”, it doesn’t take me to related references) twice. So I thought someone might find this info useful.

Basically, in order to get your Intellisense working, it is very important that your VSCode’s configuration file is set up correctly.


For me, the following config worked :

            "name": "Win32",
            "browse": {
                "limitSymbolsToIncludedHeaders": true,
                "databaseFilename": "${workspaceFolder}/.vscode/"
            "configurationProvider": "ms-vscode.cmake-tools",
            "cppStandard": "c++14",
            "cStandard": "c11",
            "forcedInclude": [
            "includePath": [
            "intelliSenseMode": "${default}"

The most crucial part above is the “includePath”, and it seems to work only when there’s 2 asterisks after the workspacefolder directory.

Further Setup

Of course, you will have to select this “Win32” configuration on the lower right corner in your VSCode GUI.

Also, if it still doesn’t work, hit ‘Ctrl + Shift + P’ and search ‘reset intellisense database for C/C++’, and after you enter that, your intellisense should work!