Disable Altitude Checks?

I’m currently running a Pixhawk 4 on rover firmware and I am running into issues during my missions. I need to set the altitude to every waypoint individually, and if they are incorrect the robot will spin around on the waypoint forever. Is there any way to simply disable the altitude checks outright, so that missions are run in 2D on the maps?