Can't flash PX4 stack to pixracer with QGC

Hey Everyone,

I wanted to give the PX4 flight stack a try, and tried to flash it using QGroundControl, but I couldn’t get this to work, whatever I tried.

I do have a pixracer, and within the ArduPilot environment everything just works. That is, for instance, flashing it with an ArduPilot firmware using MissionPlanner works with no issues (ane everything else also works).

I’m on Win7 btw.

I do have QGC installed since a while, but believe to have the latest, it says v3.2.2 in the title.

QGC nicely connects to the pixracer, with ArduPilot flashed, i.e. I do see the parameters, the HUD is working, and all that. So, this looks all OK to me.

When I’m going to the Firmware tab, and either do as advised and unplug the usb, or go there with the usb having been unpluged before calling QGC, and then plug in the usb, as told in the tab, just exactly nothing happens … absolutely no change or anything in the display, for however long I wait. The pixracer in the meantime boots and gives the buzzer and led signals I’m used to get when it boots.

It probably is just a tiny silliness of mine I’m overlooking, but I have no idea what it could be. Any suggestion/help would be much appreciated. Wrong bootloader? Dirver? No idea.

THX, and cheers, Olli

That’s weird, is this running natively in Windows 7 and not through a virtual machine or something?

Is the pixracer actually resetting when you connect USB?

You might want to upgrade to the latest QGC while you’re at it.

thx for having a look

yes, native win7

not sure what you mean with resetting … when I unplug the USB the pixracer is unpowered, right

oh, I was kind of assuming that QGC would inform me when there would be a new upgrade
so, just installed the new … same behavior
I btw didn’t like that the reinstall overwrote all user settings

in the meantime I got some suggestions from other sources, and all sound “difficult”.
frankly, didn’t expect that a simple thing like flashing the firmware could be such an effort

many thx, anyways