Tool Chain set up bash not working on Ubuntu 20.04

I had previously setup the Tool chain (successfully) for the purpose of building apps for simulation to be run in jmavsim. I accidentally deleted the directory containing all the cloned Tool chain material. I’m trying to go through the Tool chain set up process again, for Ubuntu 20.04, following the instructions @ {Ubuntu Development Environment | PX4 User Guide} but am running into problems when I run { bash ./PX4-Autopilot/Tools/setup/ubuntu.sh}. When I run the bash script, I’m met with this output:

I’m trying to get the tool chain configured for development on a pixhawk4-powered project. I’ve tried deleting the PX4-Autopilot directory and all other previously cloned material I could find and then recloning and retrying the bash script but am always met with the same output. Any thoughts?

This was resolved by unticking all the boxes in the “Other Software” tab of etc/apt/sources.list
and then running the following commands in terminal:
sudo apt-get clean
sudo apt-get check
sudo apt -f install
sudo apt-get dist-upgrade -y
sudo apt-get autoremove -y
and then retrying {bash ./PX4-Autopilot/Tools/setup/ubuntu.sh}