Starting simulation with own model

#21

@NRottmann My problem is that the backmotor’s parent is SERVO_LINK and it’s parent is the BASE_LINK. The Motor model, base plugin etc. doesnt support this type of serial linkage. I am looking to bypass that.

#22

Not off the top of my head. Have you tried giving the thrust mixer the full range? Once I see which controllers you’re using we can step through the code and figure out where it’s being constrained to [0, 1].

#23

@dagar

I have added a pull request for my simulation model (Mixers in .ros/ROMFS/... are not actualized automatically).

I also solved the problem with the output being constrained to [0, 1]. The chosen MAV_TYPE is there crucial, it may be possible to integrate an own MAV_TYPE for the AUV. Right now I just chose a convenient one to get the simulation working.

One last problem which I am facing is described here: Mixers in .ros/ROMFS/... are not actualized automatically . Maybe you have an idea why this happen?

Best
Nils

#24

i can not open the "PX4 ROS Simulation Instructions NRottmann " docs, can you upload again? @NRottmannJun '17