QGroundControl: How to Spektrum Bind when connected to Pixhawk

#2

Instead of fighting with it just bind it normally with a bind plug.

#3

You need to bind it first with your Tx then you’ll need a PPM Encoder to use that receiver or just use a Satellite Rx by itself.

Good luck.

#4

You mean use the bind plug on the receiver to connect to the transmitter? How exactly does the Spektrum Bind work, then?

[quote]You need to bind it first with your Tx then you’ll need a PPM Encoder to use that receiver or just use a Satellite Rx by itself.

Good luck. [/quote]

Alright, so would a PPM encoder like the one pictured below work, or would I need to purchase one of the first four pictured on the link you provided? I’ll provide an image of my Tx and PPM encoder below:

Thanks for the help thus far.

#5

The Spektrum bind only works if you’re only using a satellite receiver from Spektrum or Lemon RX.

If that’s a PPM encoder, then it should work.

  • So I would bind the Rx with Tx according to Spektrum process.
  • Connect the Rx to the PPM Encoder according to the appropriate pins.
  • Plug the PPM Encoder cable to the RCIN of Pixhawk
  • Calibrate the Radio per QGC procedure.

Good luck.

#6

Alright, I’ll take a look at buying one of the satellite receivers, then.

Just to make sure, the satellite receiver seems to have a 3-pin connection, so would that work when plugged into the “SBUS out” receptacle? And when you mentioned “RCIN of Pixhawk”, I assume that’s the same as “PPM RC”… or is that where the satellite receiver should be plugged in?

#7

I don’t have a Pixhawk 4 but according to what I’ve seen, it should plug in to the DSM/SBUS RC port.

Good luck.

#8

I see, even though the DSM/SBUS RC port is a 5 pin, a 5 to 3 pin connector was included, so the satellite receiver should be able to work.

I’ll update this topic when I get the receiver and try it out. Thanks for the help thus far!

#9

As Don said, do this:

  1. Plug in all of the DSMX satellite receivers (x2 usually) into your radio receiver (e.g. AR9030), they all need to be connected to the radio receiver you are going to bind to.

  2. Plug the bind plug into your radio receiver (e.g. an AR9030), power up your RX and your RC Transceiver and hold the bind plug down on the RC Remote Transceiver (I use Spektrum Black). You will hear the usual binding message.

1.1) Remove bind plugs and reboot RC Transceiver and Remote, confirm Red led on and bound.

  1. Pixhawk v2 - disconnect one of the DSMX satellite receivers from the Radio RX and connect directly to the DSMX port. Use QGroundcontrol and it will find the radio, configure RC and flight mode as documented online in PX4 Wiring guide.

  2. Pixhawk 4/5 - make a DSMX connector cable adapter to the DMUX port. You’ll find Pixhawk 2.1 and later uses Click-mate while earlier uses DF13. See here for details: https://www.lambdrive.com/depot/Robotics/Controller/PixhawkFamily/Connector/index.html

  3. The wiring for DSMX is found here:
    https://www.spektrumrc.com/ProdInfo/Files/Remote%20Receiver%20Interfacing%20Rev%20A.pdf

One thing you may want to consider, is the newer AR7700 Spektrum receiver. It has enough alt channels and you still have Pass-through on any of the Pixhawks. The nice thing about this receiver is that it does native SBUS/PPM output and you can connect directly (along with RC RSSI) to ANY of the Pixhawk flight controllers. It is also cheaper and since you don’t need all of those RC channels for most multicopters, its the better way to go. My only qualm is that it doesn’t have the RX diversity receivers like an AR9030. But then again, if you mount below your airframe I haven’t seen an issue even at close to 1/4 mile. You can find this one at Amazon, here:

Enjoy and let me know how it goes, I’ve done at least a 1/2 dozen of these already and can help you if you get stuck.

#10

Alright, so to try and summarize what you’ve said… I should just buy a new AR770 receiver that comes with a satellite receiver so I can skip the steps with the PPM encoder? That would seem to make this a lot easier, but I did buy the PPM encoder specifically for this project…

I was planning on trying rollys’s solution, so perhaps I’ll buy the satellite receiver, try that solution out, and if it doesn’t work, I’ll try what you said and I’ll only need to buy the AR770 because I will already own the satellite receiver.

#11

AR7700 does native PPM out, yes.
PPM encoder comes with Pixhawk, so yes, you could use that as well.
Or, you can wire the 3 pins on your Pixhawk 4 and make an adapter.

#12

I’ve got the satellite receiver hooked up to the DSM/SBUS RC port like you said, but the receiver does not turn on like the instructions say it should. How is the receiver supposed to be powered in this situation?

#13

Check the wiring of the Rx to the DSM port to make sure they are connected correctly. If memory serves me, it should be on 3.3v for power. The signal connects to Pin 2,

Good luck.

#14

Yes, my 5 to 3 pin connector appears to follow that chart perfectly:

All the wires seem to be going to the correct pins.

Does that mean I need to find some sort of voltage regulator to make sure it’s getting 3.3V?

#15

Did you bind it with your Tx first with it connected to the RX (AR610)? Once it’s bound, then connect it directly on your Pixhawk then do Radio calibration from within QGC.

Good luck.

#16

But how does the satellite receiver connect to the AR610? I’ve seen some of the spektrum receivers have a slot in the side for a connection to a satellite receiver, but the AR610 doesn’t have one.

#17

I’m sorry, my bad. I thought that had a satellite port. Do you have any Spektrum Rx with satellite port or can borrow one just to bind your TX to it?

Good luck.

#18

Unfortunately, I don’t, so it seems I’ll need to purchase a AR7700 receiver like jfd said.

#19

So when you connect the satellite Rx and power the Pixhawk, the satellite doesn’t power up? No LED comes on? Do you have a voltmeter to check which pin is ground and which is 3.3v?

Also, I just found this so I think it’s definitely a good idea to trace out the wiring from the Pixhawk to the satellite Rx.

Good luck.

#20

Yup, the LED isn’t coming on, and unless the wiring is backwards on the connector in the picture from earlier today, the connector seems to be a perfect fit with the chart you posted.

I’ll show a couple pictures of my setup:

And a closer look at the RXs:

It’s a bit hard to tell, but the AR610’s LED is lighted up and the SPM4648’s LED is not turning on.

#21

Try this:

  • Unplug the AR610.
  • Swap the Yellow and Red wires of the Satellite on the Pixhawk side and see if the satellite lights up.

if nothing else works, you might have to get with HolyBro.

Good luck.

1 Like