QGC Doesn't Call Out Flight Modes Setup in Switch Settings Section

I recently acquired a Skydroid M12L that doesn’t have the capability of mixing two switches into one channel as a Taranis. So, for the first time, I tried using the Flight Modes> Switch Settings and have some questions.

QGC 3.5.0; PX4 v1.8.0Dev

Tx Assignments:

  • CH6 : 3-way switch has Position, Altitude and Stabilize
  • CH10 : 2-way switch for Manual
  • CH9 : 2-way switch for Loiter
  • CH11 : 2-way switch for RTL
  • CH5 : 2-way switch to Arm/Disarm

ISSUE/ Questions: This is viewed from the Flight Modes page during initial bench setup.

  1. QGC doesn’t call out or register the flight mode when the channel is activated. I’m presuming the flight mode changes because when I switch on Loiter or RTL, it calls out “REJECT AUTO HOLD” or “REJECT AUTO RTL”.
  2. Based on the call outs above, I’m presuming the 2-way switch mode overrides the 3-way switch Flight Modes?
  3. If the above override is true, shouldn’t the yellow highlight on the 3-way turn off and only yellow highlight the actual active flight mode?
  4. I do get a Parameter Missing popup. Would that missing parameter resolve this issue in v1.8.2?

@DonLakeFlyer @dagar You input/ resolution is highly appreciated.


The yellow highlighting in QGC is just meant to let you test that a switch is connected correctly to a function. It is not meant to reflect the currently selected flight mode on the vehicle. In the case where you have multiple switches thrown at the same time you are going to get undefined behavior in QGC as to what flight mode you will really get selected in yellow.

Is that also the reason why QGC doesn’t call out the active flight mode in the Switch Settings? Is there a way workaround so that it can at least display or call out the active mode?


If the vehicle actually changes the flight mode QGC will announce it. But in this case the vehicle rejected the flight mode change so it never changed.

I “Unassigned” the 3-way switch and just used the Switch Settings panel. Assigned CH10 to Stabilize but is still not called out or register on the icon bar.

The only ones that QGC calls out is when it rejects a Hold/Loiter, RTL or Offoboard mode and Arm and Kill switch and of course the six modes under the single channel panel.


Well, here’s something interesting. QGC responds with audio call outs and Flight Mode display with v1.7.3Dev with Standard VTOL. Does this mean this issue is in the firmware?

If you are flying Multi-Rotor Manual and Stabliized are the same thing (I think). If you really want to find out what is going on you need to be talking with firmware folks. but you are in the QGC forum so you may not hit them.

I’ve reclassified this thread to Software Development as suggested by @DonLakeFlyer.

@dagar @JulianOes Could you please look at the thread and the issue/s I’ve posted for your comments on the matter?


Maybe one of you might chime in/ comment on this. Is it a bug?
@Antiheavy @ryanjAA @Kjkinney @M_Skelton @almaaro @tstastny


I’m not 100% sure I understand the issue. Flying master today, we can confirm call outs on mode change occurred on fixed wing. How the buttons are set up shouldn’t matter. Mode changes should be mode changes. Download the qgc daily version and give that a try.

Just to make sure everyone’s on the same page; I’m doing this on the bench during initial setup. It does audio call out “Reject Hold” when I choose the Loiter switch.

Humor me once. Change your flight mode setup where you have one channel on a 3-way switch then assign other flight modes to other 2-way or 3-way switches from other channels. As my example below, CH6 is on a 3-way that has Position, Altitude and Manual, CH9 on a 2-way as Stabilize; using, as you suggested, a QGC Daily Build.

When I switch CH6 to Altitude, QGC will audio call out “Altitude” and display it by the icon bar.

When I activate CH9 switch, I’m presuming it switched to Stabilize but have no confirmation since it didn’t make an audio call out on the flight mode and doesn’t show the change on the icon bar:

As @DonLakeFlyer indicated, this is a firmware issue, not a QGC one.

If you look at post #6, when I changed the airframe to a VTOL, the audio call out and icon bar display is correct, per the switch activation of CH9. And for good measure, I also upgraded to v1.8.2 Stable on the VTOL and it was working as well.


Ok - No problem. I’ll give it a try tomorrow and see what happens and write back on this.

Just following to find out if you had a chance to try this out. If you did, did you get the same results as I did?


The reason it doesn’t switch to the mode is because the vehicle presumably doesn’t have GPS signal on the bench. That’s why you only see the messages that it has been rejected.

Also, as you found some switches have higher “priority” than others. For instance, the return switch takes precedence over others.

Yes, that’s true after initial boot but once it has enough satellites, it doesn’t reject it but the change doesn’t show on the icon bar as the second image at my Post #11, it shows 14 satellites and 0.7 HDOP,

But besides that, if you look at my Post #6, with a VTOL airframe type, it does reflect and audio call out the correct flight mode as triggered by CH9 switch on the Tx. As @DonLakeFlyer mentioned, it has to be in the Airplane module/firmware as it seems to work in the Multi-Rotor code.


Hm, so this is a regression in master where the stabilized switch does not seem to work anymore?

I can only presume so. This is the first I’m using Generic Flying Wing instead of a VTOL airframe so the VTOL is my only one I can compare to.


Tested - You are right. It doesn’t call out mode changes done by switches. Tested with a fixed wing and just switches to change modes and with one switch to change the multi mode and another switch for a separate standalone mode.

So, can I presume that you’ll take care of the necessary process to file the issue and resolve it in the latest master? If so, could you post here that the issue has been resolved?


I’m not sure I follow what exactly the outcome of your tests was but I’d appreciate an issue about it.