Problem setting low values of gravity acceleration

Hello everyone,

I am currently trying to develope a new .world where gravity has a value similar to the one of Mars surface, around 3,1 m/s². However, once I run the drone into that world, it can’t even takeoff due to the following printed errors:


I have tested several g values, and it seems it does not allow any g value different from 9.81 m/s². Does someone know why is this happening? And how could it be solved?

Thanks in advance!


Remember a properly calibrated accelerometer will already have the gravity vector based on the orientation of the vehicle.

So you need to test it In that Environment because the accelerometer is sensing earths gravity field - you cannot simply change the value!

1 Like

Thanks for your answer @jfd !

That is a good point. I will follow your indications.

Thank you

Hello @jfd . I have been doing some research since last response. I am developing by the moment in SITL, so where should I change the value of the gravity acceleration if i want a value different from 9.806. In accelerometer_calibration.cpp?

send me your test setup and git hash and I can take a look sometime when i am free