Pixracer with px4_simulink_app problems ([pwm] can't open /dev/pwm_output0)


I got a Pixracer r15(FMUv4) last week, and I try to move my project to it (I have successfully upload my project to Pixhawk, and check everything is working).

The problem is that I cannot see the rc input signal and the motor pwm output signal when I start the px4_simulink_app in the rc.txt and connect my Pixracer to the Qgroundcontrol.
I check the uORB Graph and the rcS, and I find that unlike Pixhawk(FMUv2) using px4io, Pixracer uses fmu to handle IO. Therefore, I try to open fmu by typing “fmu start” in the Mavlink Console of Qgroundcontrol, and then I can get the rc input signal, but there’s still no pwm signal. To figure it out, I type “pwm info”, and it shows “ERROR [pwm] can’t open /dev/pwm_output0”

The same error happens not only for my project but also for the px4demo_PWM example.

It looks like there’s some conflict between fmu and px4_simulink_app?
Any help would be really appreciated!


I upload the PX4 v1.10.1 Stable Release Firmware to Pixracer, and find that the fmu is running, so I’m wondering why there is an error in pwm when I start fmu and the px4_simulink_app(I set the PWM output to Device: /dev/pwm_output0)?


I want to know if you have solved this problem, because I also encountered this kind of problem