Pixracer R14 FrSky X4RSB Taranis X9D+ Telemetry not Working

Hi, everyone!

I’m trying to setup a sub 250g mini drone that uses a Pixracer R14 flight controller running Ardupilot firmware. Everything is okay, except FrSky telemetry. My first try was using FrSky R9M module and R9Slim receiver. I tried for 2 days and gave up, because telemetry did now work.

Now, I’m trying using my Taranis X9D+ connected to a X4RSB receiver, all with updated firmware. My connections can be seen in the 1min video I’ve recorded right now specially for this post (link below).

I followed every single step in the PX4 instructions page, and tried some variations too, but without success. So, I really hope somebody can help me. I will use this drone for my PhD experiments and I need this working as soon as possible… :frowning:

By the way, if someone got telemetry working using Pixracer R14 with R9M module, R9Slim receiver and Taranis X9D+, please, tell me how to do it. My first desire is to use R9Slim, because of its range.

Thanks in advance!
Best regards.

Hopefully this will lead you to the right direction:

Good luck.

For ArduPilot assistance, best to visit the ArduPilot forum: discuss.ardupilot.org

Hi, everyone.


I just setted the paramenter SERIAL4_PROTOCOL to 4 and started receiving all 13 telemetry values from Pixracer R14 running Ardupilot/Arducopter 3.5.7. The receiver is X4RSB. Now I will try with R9Slim receiver.


Hi, again.

Not working with R9Slim receiver. Any idea?