Pixracer - 1.5.3 Stable - RTL Fly Away

I flashed last week the Stable version of 1.5.3 on my pixracer and I have to admit that I was very pleased with what I saw. All flight mode (Stableized, Altitude, Position) worked well. Today I did some more test on my PixRacer test quad and I hade some fun but also some strange behaviour. I still don’t trust the firmware totaly.

For example I hat a fligh away while testing RTL. Why? One flight later everything was fine and I tested RTL about 4-5 times everything worked fine.

Here ist the log of the first flight, something seams to be going on in the mag field if I don’t miss understand it.

An here is the second flight, to me it seems pretty solide result. I’m happy but not confident that some time it seams to work and sometime no.

It looks like you have a setup issue with your mag - is it close to current (the climb during RTL is high current) or did you maybe mount it non-standard and forgot to configure its orientation correctly?

The first image is a normal log. You can see that the mag innovations are fairly low. The second image shows your log and that something about the mag heading is not right.

Needless to say this will continue to be unreliable until you fix the system setup. If the magnetometer measures an incorrect system state there is nothing we can do.

Note how the mag X, Y and Z innovations spike, suggesting the magnetometer is inconsistent with the rest of the system.

1 Like

Hi @LorenzMeier,

I just flashed the latest Master and went outside to hover around. It’s dark and I don’t want to test the RTL in the dark. The Log looks okay to me, what do you think?


I will do some more test tomorow and look the logs.

Looks pretty good to me.