Pixhawk 4 not seeing airspeed sensor

#1

Hi everyone!!

I have been also struggling with getting my airspeed sensor working. I have done a lot of searching but found no solutions yet. Heres is my current set up:

Flight controller: Pixhawk 4
Firmware: PX4 1.8 (Running standard fixed wing aircraft)
QGroundcontrol version: 3.2.4
Sensor: px4 airspeed V1.3 (Sold by Holybro. Link: https://shop.holybro.com/digital-air-speed-sensor_p1029.html )

My issue is that when I click calibrate I receive these messages:

[cal] calibration started: 2 airspeed
[cal] No airspeed sensor found

Here are the things I have tried:
-Twisted all cables
-Tried different cables
-Swapped I2c lines
-Research and check params relating to airspeed sensor
-Drop logic level lines from 5v-3.3v (More on this)
-Through finding a sensor (Lost the link to it) sold specifically for the Pixhawk family, claiming that it was unique because it had a level shifter onboard that dropped the I2c lines from 5v to 3.3v. Implying that most other sensors ve their I2c lines at 5v. I looked at photos of it closely and it did have more components on it compared to all other px4 airspeed sensors on the market so this gave me mild justification to believe that my sensor has its I2c lines at 5v. A long shot, I know, but im looking for anything now. I have been struggling for a long time on this. For this reason I bought a I2c level shifter from sparkfun and wired it in to drop my I2c lines from what I believe to be 5v, down to 3.3v.

After all this I still get the same error and i’m pulling my hair out. Im not sure if im just being foolish and doing something incredibly simple wrong, or what else is going on, but any help would be appreciated. If your asking why I haven’t bought the other sensor that says its made specifically for the Pixhawk, its because I blindly closed the web page a week ago and of course, didn’t have it bookmarked.

Thank you in advance for any input, and if you know the sensor im talking about, a link would be much appreciated.

#2

Hello ,

I also have same controller and airspeed sensor from Holybro.
I also had same problems as you with standard firmware.
(And I also tried most of things you listed)

Try to setup firmware again, but choose: “Advanced settings” --> Developer build (master)

#3

Hi @berserk,

Thanks for the tip! Have you confirmed that this fixes the issue? Is the developer build stabil?

Thank you!!

#4