mRo Control Zero - Settings not sticking AND switch ChibiOS with NuttX

Hello everyone.
I’m having some issues with mrO’s Control Zero F7 FC’s. At this moment I have two of them.
One doesn’t boot at all and the other one boots and can be connected to QGC or Mission Planner but whatever setting I change (for instance Airframe Type in QGC) and then reboot it’s always back to defaults or “no settings”.
It sometimes reports a missing FMU SD card too, although it’s inserted.

I had this one flying under Ardupilot once but with terrible oscillations and there isn’t even any kind of PID tuning (that I could find) in MP and QGC doesn’t support its PID tuning with Ardupilot.

Why are the settings not sticking under PX4?
How can I get rid of that horrible ChibiOS thing and finally switch to a nice and neat NuttX?

Reaching for any straws here…
thanks for considering

Hi Christian-Born
Have you found out anything about this issue in PX4? I have a Control Zero F7 as well and it has problems with the SD card too. It says that no SD-card is detected even though it is inserted and works (I can read and write if I connect it to my computer and I have also tried to reformat it.) The parameter changes vanish as well after a reboot.

It would be great to get a hint or two.

Hey there, tbh I solved this by acquiring a newer version of the PCB…
Like, the blue one which works all fine and dandy with PX4 and QGC…
I think we have the “classic” version which seems just not be supported well by PX4 at all.
Sorry to say.
try Ardupilot… :man_shrugging: