Logging problem in 1.6.5 with SDlog2

Dear VTOLers and developers,

I have a strange problem with logging:
I’m using FlightPlot since ~1 year to analyse my flights, and so far it worked fine for me.
Default Logger was SDlog2, I never changed it before.

Currently I fly 2 vehicles, both in “Standard VTOL FunCub” configuration:

  1. Vehicle1: VTOL-Plane: PX4 1.6.5, on 3DR-Pixhawk (like this 3DR PX4 Pixhawk Advanced Autopilot (w/ GPS) - RobotShop)
  2. Vehicle2: a Copter: PX4 1.6.5, on Unmannedtech.uk Pixhawk (Unmanned Pixhawk Autopilot Kit – Unmanned Tech UK FPV Shop)

The other components are 99% the same.

Vehicle2 works fine on 1.6.5, logger is SDlog2, logs *.px4log files, can be opened in FlightPlot. Perfect!

Vehicle1: Problems started after updating on 1.6.5 (flew on older version before).
Interestingly during update the Logger type changed itself to “Logger” (new). Noticed this after flying. The *.ulg logfiles worked in FlightPlot.
But I wanted to change back to SDlog2, because I have all my Plotting-Presets prepared for *.px4log files.
The *.px4log files are created during flight. But when I open them in Flightplot, I always get the error message “java.nio.BufferUnderFlowException”.
Can’t acces the logfiles.

Any ideas?

I read somewhere about different flash sizes. Maybe the (older) 3DR-Pixhawk has less flash memory and can’t run the current 1.6.5 firmware with SDlog2?
But the *.px4log is created, size looks normal. Just can’t open it.

I’m thanks full for any advice!


There is an error in the differential pressure data logging in SDlog2 which breaks the processing scrips/Flightplot. This PR should fix it probably also for you: https://github.com/PX4/Firmware/pull/8058

Hi Florian,

great, thanks for your reply and fixing the bug!
Makes sense that it has to do with the airspeed-sensor. That’s the reason why it worked on Vehicle2, a Copter, because it has no airpseed sensor.

How can I get a PX4 version incl. this bug fix on my plane?
While updating the firmware, can I use “Beta testing” version or “Developer build (master)”?
Or do I have to compile myself? (haven’t done this yet)

Thank you!
Best regards,

I think once the PR is merged to master you could user the “Developer build”. Until then you would need to change the code by yourself, compile it, and flash the Pixhawk by yourself. Refer to this page on how the building and flashing of the PX4 is done: Building PX4

Thanks Floarian!
Will try that!