How propertly fork attitude controller code to implement autogyro control?


I have made several attempts to use existing fixed wing controller to fly a gyroplane ad I decided the code need to be modified to implement autogyro specific pitch control.

Have you some suggestions on how to properly name the new attitude controller? Could I anticipate from modules/fw_att_control/FixedwingAttitudeControl.cpp the new code should be named modules/rw_att_control/RotorwingAttitudeControl.cpp ? I suppose similar name modification for other files too.