Gazebo's simulation compile errors on MAC

I encounter gazebo errors while it is compiling with my Mac.I ran gazebo on my CatalinaOS v10.5.1 very well before. But it can naver compile successfully after that I updated my code from v1.11.0 to v1.12.0. Even I have formatted the whole disk of my Mac.And reinstalled Big Sur v11.5.1.Then I reinstalled everything as the instruction carefully. It still get the very same errors as before.
Why and how to fix it?
Here is the whole output of the compiling:

 [0/5] Performing build step for 'sitl_gazebo'

[1/108] Building CXX object CMakeFiles...lugin.dir/src/gazebo_wind_plugin.cpp.o

FAILED: CMakeFiles/gazebo_wind_plugin.dir/src/gazebo_wind_plugin.cpp.o

In file included from /usr/local/include/gazebo-11/gazebo/transport/transport.hh:3:
/usr/local/include/gazebo-11/gazebo/transport/Connection.hh:57:65: error: expected class name
    class GZ_TRANSPORT_VISIBLE ConnectionReadTask : public tbb::task
/usr/local/include/gazebo-11/gazebo/transport/Connection.hh:73:20: error: no type named 'task' in namespace 'tbb'
      public: tbb::task *execute()
/usr/local/include/gazebo-11/gazebo/transport/Connection.hh:313:61: error: no member named 'allocate_root' in namespace 'tbb::v1::task'
                  ConnectionReadTask *task = new(tbb::task::allocate_root())
/usr/local/include/gazebo-11/gazebo/transport/Connection.hh:315:19: error: no type named 'enqueue' in namespace 'tbb::v1::task'; did you mean 'ifqueue'?
/Library/Developer/CommandLineTools/SDKs/MacOSX11.1.sdk/usr/include/net/if_var.h:230:9: note: 'ifqueue' declared here
struct  ifqueue {
8 errors generated.