Detected 0 radio channels. To operate PX4, you need at least 5 channels

#16

Hi all I use FrSky Q X7
and receiver X8R with Pixhawk 2.4.8
and I got problem with pairing it with QGrounControl.
I also tried @Sparky002 advice but didn’t help.

I got firmware version 1.8.0

Thanks for any another advice.

#17

Make sure that the polarity of the cable from the X8R SBUS (not SPORT) port is connected properly to the RC IN of the Pixhawk.

Good luck.

#18

Old thread, but for anybody finding this thread in search of wisdom.

Using the standard DSM/SBUS RC to FrSky XSR cable delivered with the Pixhawk4, with a R-XSR receiver you have to move the yellow wire from pin 1 to 2, in the R-XSR side of the cable… (Default connected to SBUS in, pin 1on the R-XSR, shall be connected to SBUS out, pin2)

1 Like
#19

hello had my x8r working, upgraded a few days ago and i have the same problem once again ,for one i never got my r9 slim or my r9 slim + to detect any channels and now x8r has no channels detected either. i also did what Sparky002 suggested,double checked what Yuri suggested,and what Rollys said with no luck the only reason that i messed with it was because i paid alot of money for uhf set up and i was hoping a later up grade would fix the problem anyway can any one tell me how to use a qx7 Taranis with r9 slim + receiver connected to Qground control with Pixhawk4 fmuv5 ,Who wants to make a video i’ll be your no. 1 fan HELP anyone PLEASE thanks

#20

The R-XSR come with a plug ready to use S.PORT (Smart Port) and not SBUS.

Original S.PORT plug:

Amended plug for SBUS:

You can then connect it to RC-IN on the Pixhawk and it is solved :wink:

#21

Hi
I used WFLY ET07, RF207S, CUAVv5 and 1.7.3 or 1.8.0, I also found this question

#22

Hi
When should I unloose the switch? Thanks

#23

I have the same problem, I am using 3DR PX4 with QGC and recently updated to the latest firmware suggested. I use Taranis Q X7with X8R on SBus mode. I connected properly.

The problem is whenever I use USB I can get the board connect to the RC, but if I plug in the power, the RC stops moving. Thus the calibration never get completed.
This problem persists even though I tried flashing it, factory reset or even change to mission planner.
I worry it is a hardware problem? Or may be there is something I can do to save my board?

#24

Oh yes one thing is that this happened after I update the PX4 stack firmware. I don’t know the procedure to downgrade. Would it help?
Any help appreciated. Thanks.

#25

Presuming the wiring is correct on both ends (GND or - on top with Pixhawk and GND pointing inward on X8R), the X8R will power up (solid green LED) when USB cable is plugged in; you don’t need a separate battery to power up. If this is not the case, your SBUS wiring is wrong, either on the Pixhawk or X8R side or both. You should be able to calibrate the Radio with just USB providing power.

Good luck.

#26

Thanks for the quick reply.
I am sure the wiring is xorrect because qt first using usb the rc display on qgc was responding ok, but as soon as i powered or sometimes even before i powered it, it just stuck, hanged.
Also i check the X8R using a servo was working fine.

#27

I did not separate the power to X8R. It solely powered by pixhawk.

#28
  • Unplug the USB from FC.

  • Turn on Tx.

  • Plug battery to power to power up FC.

  • Does the X8R LED turn on solid green?

  • If it does, then plug is USB.

  • Check QGC for responses.

  • If the X8R doesn’t turn on, are you using a power module?

  • If you’re not using a PM, connect a servo cable from the FC MAIN8 port to X8R channel 8 and confirm it comes on.

  • Connect the USB and confirm QGC responses.

Good luck.

#29

Dear rollys, thanks for the reply.

I just did what you suggested. I wonder why it was not working.
I attached link to my video.to see what I got wrong. Tx

#30
#31

Sorry for error upload…

#32

I tried to what you suggested, the light is solid green but still qgc not responding. Could this be a firmware error and I should downgrade, or could it be hardware? Or something else. Tx.

#33

Hi rollys there is a progress. I downgraded to 1.8.0 stable fw as you suggested. Thanks. It turn out that QGC displays the RC movements. But whenever I connect the power (with or without BEC power to the X8R) the QGC fails to detect the RC.
But if I connecti using USB, QGC always detects it.
It never happened before I downgraded to 1.8.0.
Did I miss something here?
May be something to do with the power module?

#34

Hi, it seems that I still have no solution.
If I can sum up

  • Frame type Hexa
  • FC 3DR PX4 with QGC firmware
    ÷ Receiver Frsky X8R using Sbus.
    My attempts:
    -Tried X8R Sbus with USB - OK but when connect to the battery, it becames undetected.
    -Tried XRS receiver Sbus and CPPM with USB worked OK, but when I connect to battery it also became undetected.
    -Tried changing power module. Same
    -Tried using Radiolink PPM usb ok battery no.
    Anyone can help please…
#35

Hello

I have the same problem with a Spektrum DX6i and satellite receiver used woth a Pixracer…
I plugged the three connections of the satellite in the RCIN in this order:

  • gray (signal) to RCIN (white)
  • black (GND) to black (GND)
  • orange (3.3V) to orange (3.3V)

On the RCIN port of the Pixracer, the green (RSSI) and red (5V) are left unconnected.
The satellite is binded (steady orange led), but I have the “detected 0 channels…”

Any help is appreciated!