Airspeed Sensor problem

Hello, I am using pixhawk 6C and Qground control. I have connected MS4252DO (Digital Air Speed Sensor – Holybro) digital speed sensor to I2C port.

SENS_EN_MS4252DO in parameter is already enabled.

I have selected the generic quadplane VTOL airframe and while calibrating airspeed sensor, i am receiving message “Calibration failed: airspeed”

Should I enable any parameter or add something?

Thanks in advance for your time.

Is there any reading on the Airspeed meter? If there is no reading then the sensor does not work.

If the sensor is working it would show you some numbers in the Airspeed meter. Might be totally off but still you sill see reading.

Might be a defective sensor, might be a bad I2C cable.

Thanks for the reply.
The problem is solved.

When i first connected directly to the pixhawk 6c there was no reading, I tried connecting speed sensor to the Arduino and there were reading from -2500 kt to 8000 kt.
Later I connected to the pixhawk 6C with the same cable to I2C and i was able to calibrate it and now i am getting reading somewhere around -1.2 m/s to 1 m/s when it is lying on the table.